• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Electro-Voice PXM-12MP report

Nextinline77

New Member
Hm....what does static decay sound like..? Bosch told me, two months ago, that the issue has been fixed in the current production line. I sent mine back to Thomann a month ago, but it seems I'll have to wait 4-5 more weeks for a new one. Not sure what's up...
I'm not sure how to upload video to this forum but even if I did the camera quality on the iPhone makes it difficult to hear. It's very apparent if you test the speaker with a bass. Buzz, static, distortion, I suppose they could all mean the same thing depending on who's listening. If you run a bass through the speaker, sit next to it, and give it a little volume you'll hear it right away if something is wrong.
 

jazzgtrl4

Experienced
Unfortunately, this speaker didn't pan out for me. EV has been back ordered on parts and the turn around time to get my unit back was about 6 weeks. When I received the repaired unit back from EV they said they confirmed the distortion issue and replaced the woofer. Upon testing the new unit seems to have a slightly different issue. As opposed to a straight up distortion on the low frequencies there's now a static decay on the end of my notes. EV offered to repair the unit again but I'm not willing to wait any longer at this point for a speaker that may or may not ever be right. With the supply shortages Sweetwater doesn't have any more in stock to swap this one out so it's unfortunately been returned. It really did seem like a great design at a solid price point but it's more trouble to me than it's worth at this point. I suppose I'll look into Xitone or potentially even building my own with the F12-X200.

ya to bad....mine work and sound great.
 

guitarnerdswe

Fractal Fanatic
I recently got both of my units back from Thomann. It took 27 days, and during that time they went back to Bosch for the actual repair.

I got documentation with them that state that the PCBA amplifier has been replaced on both units. Both work fine now, and the firmware is the same as before, so it's a part issue. One of the documents was in German, and mentions a couple of abbreviations. Perhaps product range names, or part names? Attached below.

EDIT: Found the part (or something really similar). So yeah. they basically swap all the electronics that aren't related to the software or UI.

https://www.artsound.gr/product/ele...ifier-power-pcb-board-p-n-f-01u-317-470-part/
 

Attachments

  • _20210908_134332.JPG
    3.8 MB · Views: 23
Last edited:

Dave Merrill

Fractal Fanatic
I recently got both of my units back from Thomann. It took 27 days, and during that time they went back to Bosch for the actual repair.

I got documentation with them that state that the PCBA amplifier has been replaced on both units. Both work fine now, and the firmware is the same as before, so it's a part issue. One of the documents was in German, and mentions a couple of abbreviations. Perhaps product range names, or part names? Attached below.
So they sound ok now? I hope so!
 

greiswig

Power User
I recently got both of my units back from Thomann. It took 27 days, and during that time they went back to Bosch for the actual repair.

I got documentation with them that state that the PCBA amplifier has been replaced on both units. Both work fine now, and the firmware is the same as before, so it's a part issue. One of the documents was in German, and mentions a couple of abbreviations. Perhaps product range names, or part names? Attached below.
Mine listed replacement parts, too, but I don't know where that documentation is. But it sure fixed the issue for me with both my speakers. Great speakers made even better.
 

Greg Ferguson

Fractal Fanatic
I have a pair of these, have had them out three (?) times for several hours at a time, and have really liked their sound.

They have storable EQ settings if you want to adjust their response. I use the second monitor curve which appears to be the most flat setting.

I added additional feet to the cabinets so I could rest them on their bottom/side without tearing them up when loading and unloading the car.
 
Last edited:

ElectricPhase

Power User
I'm considering a pair of these, but I wouldn't want to mess around with returns or factory repairs. Is there any outward indication of whether they are the corrected version?
 

Sixstring

Axe-Master
I'm considering a pair of these, but I wouldn't want to mess around with returns or factory repairs. Is there any outward indication of whether they are the corrected version?
It doesn't appear that there is any thing on the units that indicate a fix or that they have been corrected. I didn't see anything either and the problems seem to be mostly in the E.U. At least thats what it seem like here in the board.

@Greg Ferguson posted...

I talked with one of the support people.

The units with the problem were early production and were corrected. People who get one with the problem can get them fixed free. And the problem is supposed to be be pretty obvious.

I couldn’t get him to specify a serial number range and there’s nothing specifying the production date on the units that I could see.
 

greiswig

Power User
My humble opinion: they're worth the risk. I bet many people wouldn't even notice the level of IM distortion I was hearing from both of mine, and Bosch pretty quickly fixed them. They sound really, really good. And they are very flexible. Don't let this minor quibble that can be fixed stand in the way of you getting a great FRFR.
 

Lionfeather

Inspired
I agree they sound great. I had the issue with a pair, got them back one was fixed the other still had the issue and sent it back to them.
They supplied be with a shipping label so my only cost for service has been time.
They are waiting for parts which they expect Oct 10.
 
Top Bottom