• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Lag when recording in Logic Pro X

Wojtek12as

Member
Hey !
I noticed that when I record my guitar parts, they always seem to be a little too late. I struggle with this issue for some time now. I kind of found workaround for this issue by setting recroding delay in Audio settings in Logic pro X, but I doesn't seem right for me. I have my input monitoring off, I mute the track when I record. What else should I change to finally resolve this thing ?
Thank you !
 

rodzimguitar68

Fractal Fanatic
Plugins could be causing the timing issue. If you want to reduce the load on your CPU, Freeze all of your tracks, except for the ones you are arming to record.

The culprit for me is always OZONE mastering plug-in. It is not enough to bypass the plugin. I must delete it from the session. So, if I've enjoyed hearing a more full mix with the plugin inserted, I go into the plugin and save as the settings in the plugin so I can safely delete it from my master channel, finish tracking more new stuff, and then re-insert the plugins and recall the saved preset for that song.

Although LOGIC should calculate and adjust for latency, you can help your chances by setting the buffer to a lower amount, like 125-250ms to record, and then set it to maximum, like over 1,000 to mix.

Good luck.
 

PincoTech

Experienced
Hey !
I noticed that when I record my guitar parts, they always seem to be a little too late. I struggle with this issue for some time now. I kind of found workaround for this issue by setting recroding delay in Audio settings in Logic pro X, but I doesn't seem right for me. I have my input monitoring off, I mute the track when I record. What else should I change to finally resolve this thing ?
Thank you !
record in "low latency mode". To the right of the transport, there's a button.
 

bern

New Member
Have the same problem in Pro Tools.... has nothing to do with "low Latency mode". It is a recording offset. I am still looking for a solution ....
 

rayza

Member
Is the Axe3 your interface? have you played with the usb buffer settings in the axe?
 
Last edited:

PincoTech

Experienced
The recording offset can be calculated using a formula, or by recording the “latency”, next to a sample accurate track, then measuring the difference. It’s been a few years since I’ve had Any issues, and I can’t remember the exact method, but once you have the offset calculated properly, you’ll have no more problems.
 

PincoTech

Experienced
PC or Mac?

I’m running a MacBook Pro Intel I7 quad core, w 16gb of ram, and an SS hard drive.

My I/O buffer setting is 64 samples, with a round trip latency of 7.9ms using the axe Fx III as the only interface. My recording delay is set to -307 samples. Mutitthreading is set to “playback and live tracks”

higher buffer number = higher general latency.
Try for the lowest stable buffer size possible. The AXE FX III is GREAT as a dedicated interface, and often overlooked in that regard.


Also, are you trying to record @ 192khz 24bit? The highest settings require extremely fast cpu/ram/throughout/round trip execution, and don’t offer all that much benefit, with the current conversion back to 44khz anyway. Yes higher settings have other benefits, but I find that anything higher than 88khz is unnecessary. I’ll either record at 88, or 44, and end up with killer results.
 

PincoTech

Experienced
And why would you want anything more than 48Khz ? If you think it’s absolutely necessary then use a thunderbolt 3 interface, or how about RE-amping? Record a di, then re-amp and print at 192/24 bit.
 

PincoTech

Experienced
And why would you want anything more than 48Khz ? If you think it’s absolutely necessary then use a thunderbolt 3 interface, or how about RE-amping? Record a di, then re-amp and print at 192/24 bit.
The quality you can get out of 48khz from the AXE FX III into Logic, double or triple tracked is mind blowing.
 

Kamil Kisiel

Power User
I didn't say you would, just that you said "I'll record at 88 or 44", which you can't do if you're using the Axe-FX as your audio interface.
 

PincoTech

Experienced
Oh, I got you. I used to use Bias Pro to track at higher sample rates before I got the Fractal. I’ve had some pretty elaborate studios in the past, and always focused on making things better once in the daw, but with the fractal, the raw tone is so full, and alive that getting a great take became the most important thing. Heck once you have a great take you can even change amps, if you want.
 

Wojtek12as

Member
PC or Mac?

I’m running a MacBook Pro Intel I7 quad core, w 16gb of ram, and an SS hard drive.

My I/O buffer setting is 64 samples, with a round trip latency of 7.9ms using the axe Fx III as the only interface. My recording delay is set to -307 samples. Mutitthreading is set to “playback and live tracks”

higher buffer number = higher general latency.
Try for the lowest stable buffer size possible. The AXE FX III is GREAT as a dedicated interface, and often overlooked in that regard.


Also, are you trying to record @ 192khz 24bit? The highest settings require extremely fast cpu/ram/throughout/round trip execution, and don’t offer all that much benefit, with the current conversion back to 44khz anyway. Yes higher settings have other benefits, but I find that anything higher than 88khz is unnecessary. I’ll either record at 88, or 44, and end up with killer results.
I use mac mini from 2018 with i7 and 16 gb of ram. Thank You for answer I will try your suggestions and will let you know if it resolve my issue !
 

PincoTech

Experienced
Plugins could be causing the timing issue. If you want to reduce the load on your CPU, Freeze all of your tracks, except for the ones you are arming to record.

The culprit for me is always OZONE mastering plug-in. It is not enough to bypass the plugin. I must delete it from the session. So, if I've enjoyed hearing a more full mix with the plugin inserted, I go into the plugin and save as the settings in the plugin so I can safely delete it from my master channel, finish tracking more new stuff, and then re-insert the plugins and recall the saved preset for that song.

Although LOGIC should calculate and adjust for latency, you can help your chances by setting the buffer to a lower amount, like 125-250ms to record, and then set it to maximum, like over 1,000 to mix.

Good luck.
OZONE is a monster plug in that uses a ton of resources. Thats also why its so good!
 
Top Bottom