• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Lag when recording in Logic Pro X

PincoTech

Experienced
Directly to my Mac, no hub's :)
Okay. Last thing is, while you're tracking, do you have "low latency" mode enabled? If i don't enable it on my Mac, i can't get sub 8ms roundtrip latency. If that doesn't work, then you need to calculate the proper sample delay for your setup. you're running a 2017 mac I7 16gb correct? mines a 2013, and i don't have any issues. if anything your mac should be faster, and more efficient. Rayza was right about the hub thing too, but if your running usb direct, there's no bandwidth being shared. One other thing, are you using software synths? i keep my entire sample library on an external SSD. Are you having troubles with latency on the very first track being recorded in logic, with no plug-ins inline during recording? I'm going to try my best to get you up and running smooth
 

PincoTech

Experienced
Okay. Last thing is, while you're tracking, do you have "low latency" mode enabled? If i don't enable it on my Mac, i can't get sub 8ms roundtrip latency. If that doesn't work, then you need to calculate the proper sample delay for your setup. you're running a 2017 mac I7 16gb correct? mines a 2013, and i don't have any issues. if anything your mac should be faster, and more efficient. Rayza was right about the hub thing too, but if your running usb direct, there's no bandwidth being shared. One other thing, are you using software synths? i keep my entire sample library on an external SSD. Are you having troubles with latency on the very first track being recorded in logic, with no plug-ins inline during recording? I'm going to try my best to get you up and running smooth
Oh and please tell me your not running Catalina, because its barely supported by anything at the moment. i was warned by Waves, Positive Grid, among others not to even try it. any program that runs in Catalina has to be re-coded in 64 bit, and that's a monumental task for a lot of the third party companies
 

Wojtek12as

Member
Oh and please tell me your not running Catalina, because its barely supported by anything at the moment. i was warned by Waves, Positive Grid, among others not to even try it. any program that runs in Catalina has to be re-coded in 64 bit, and that's a monumental task for a lot of the third party companies
OK so I checked couple of options. I opened new project without any plugins and there was some lag when recording. I opened the fully loaded project with plugins an its the same. There is a difference when I have a lot of plugins on master track - the lag is even bigger. To be honest I didn;t have those issues on my axe fx2. I have checked it on catalina and on high sierra and mojave - always the same issue. I have 2018 - with 6 core, 12 threads i7 and 16gb drr4 2666, it is fast enough. I had the same issue on my hackintosh.
 

Wojtek12as

Member
With input monitoring you're listening to the output of the interface BEFORE it goes on its round trip through the system.
But it is fine when I play, I don't have any latency, problem is when tracking takes into the logic. You can see that every bar is a bit late. I thought that this happens due to my lack of skill but it is impossible to be always equally to late in every take :D
 

PincoTech

Experienced
Nope ! I will check that later on, thanks :)
You’re welcome. Input monitoring bypasses all latency while recording. Don’t be fooled by a slightly different sound while it’s being tracked in some cases because of plugins on the armed track, not sounding. On playback, the sound will be exactly as intended.
 

DougB415

Inspired
What is your buffer setting? Just in case you (or others) don’t know, use a high buffer setting when mixing. Use the lowest buffer setting you can when recording.
 

Admin M@

Administrator
Fractal Audio Systems
Moderator
I've been asked about this lately elsewhere and I am going to try to get an answer from Apple.

I think what you're describing is as follows:

1. You record an Axe-Fx III USB track in Logic, playing perfectly in time with backing tracks.
2. When you play back audio, the recorded Axe-Fx track sound late.
 

Wojtek12as

Member
I've been asked about this lately elsewhere and I am going to try to get an answer from Apple.

I think what you're describing is as follows:

1. You record an Axe-Fx III USB track in Logic, playing perfectly in time with backing tracks.
2. When you play back audio, the recorded Axe-Fx track sound late.
Yes thats exactly the issue ! It actually is too late, not only sounds to late :) I zoom in the DI track and analize every bar and I can see that it is equally to late in every take, every bar etc :)
 

Warrior

Power User
I would suggest downloading "Reaper" and try recording with it to see if you have the same issue.
You can use the free trial so there's no cost to try it.

If there's no issue, maybe that will help to pinpoint the issue within Logic?
 

plyall

Power User
To 'mwd's point - what versions of Logic and the OS are you using? Catalina has been catastrophic for audio, so stay on Mojave (or earlier).

Also - Logic's latest release is a bit of a train wreck... The last really stable version was 10.4.4. The current version is 10.4.7 (don't do it).
 
Top Bottom