• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Input pad above 0db = distortion in recorded playback no matter the guitar?!

Skippzore

Member
Edit: Mark Day over at Fractal guided me via email. After some resets and testing, he ended up recommending me to contact G66 for a warranty claim. He said
The Input pad setting should have no effect because as you probably know when we PAD the INPUT to the convertor we inversely boost the OUTPUT of the convertor. If the input pad setting is causing distortion it could mean that the unit requires service, please work with G66 going forward.
__
FM3 is running 4.00 beta 2.

TL;DR

Direct signal gets distorted during recording in DAW when using input pad above 0db no matter what guitar I use. Direct monitoring sounds just fine, only the recorded sound gets distorted. 0db input pad no longer has me tickling the red but actually mostly being in the red, which probably is an issue. I was on 6db pad previously which had me tickling the red.


I edited this post to remove mention of another issue regarding recording latency that was solved
___

While trying to see if the latency compensation worked, I made a preset with nothing but INPUT1 -> OUTPUT 1 (no amp, cab or anything) and tried to play as tiiiiight as I could, just to verify.
What I noticed was that the audio recorded in reaper was distorting when I played it back. I rendered it and listened to it again and it was still distorting. I was surprised because it sounds just fine when playing it straight to the speakers. It's just the recording that sounds funky and distorted.

Because of this, I messed around with the input pad which I previously had set to 6db (which was perfect for just tickling the red) and by setting the input pad to 0db, the distortion in the playback from Reaper stopped. It sounds just fine. Or well, more like how I expected a direct signal to sound.
Anything above 0db on the input pad makes the audio distort when playing anything above moderate attack when playing it back in Reaper. The problem is that with 0db I'm not just tickling the red, I'm full on assaulting it. Nearly everything I play puts me in the red, and striking any kind of chord has it staying on red for quite a while. That can't be good?! Although it does sound the same coming straight from FM3 to my speakers as it did with the 6db pad.

I have attached a picture of the waveforms of my two recordings where the first one sounds distorted and the second one sounds fine. They both look like they're clipping or maxing out but Reaper isn't registering either of them as clipping.
Here's an audio clip of what attached picture sounds like (VOLUME WARNING):


My guitar is a Strandberg Boden 7 Original with Fishman Fluence modern pickups. I know they're pretty hot pickups, but it kinda doesn't feel right. Tried changing the battery of the pups just to make sure and it did nothing.
Putting an amp and a cab and making a normal clean preset sounds fine with both settings. Maybe I'm just inventing a problem that has no real effect, but I just want to make sure that my input isn't clipping even though I can't hear it. I assume that would make me lose a lot of headroom and detail.

I tried recording with my Ibanez RGA121 with Bareknuckle Blackhawks (passives) and the problem is actually persistent on that guitar too! Soundclip of chords being strummed at moderate attack. VOLUME WARNING!


Same issue there regarding literally murdering the red at 0db and just tickling it at 6db. Any tips? Should I keep the input pad at 0db even thought it's nearly always on red? Why is this happening?

Sorry for the long thread, I suck at keeping things short. Thanks in advance for any replies.
 

Attachments

  • reaper_GGo5QvTBdG.png
    reaper_GGo5QvTBdG.png
    119.8 KB · Views: 8
Last edited:
Are you recording with direct monitoring? And is there any latency of any kind when your just jamming with the FM3 and not recording?
 

Skippzore

Member
Are you recording with direct monitoring? And is there any latency of any kind when your just jamming with the FM3 and not recording?

Yeah I'm using direct monitoring. No latency when just jamming with the FM3. It's just the recorded tracks that seem to be recorded a bit too late. But as I wrote in the post, that issue is "fixed" by adjusting the "manual offset latency" in Reaper in accordance with the video I attached. The recordings line up a lot better (perfectly, perhaps?) now.
 
Sorry Dude, It looks like you already figured out the latency issues. As far as the distorting, you say your ibanez DOESNT give you that distortion? You dont have access to another guitar do you? to eliminate the possibility of the pick ups?
 

DaveO

Power User
Here is my ASIO setting in the driver, I'm using Cakewalk, try disabling your laptops onboard audio card in the bios.


1622616503812.png
1622616565552.png
Here is the settings in CW
1622617316597.png
 
I would probably come to the same conclusion you did.....Its something with the pick ups....as far as dealing with it....In my opinion, I would concern myself with the way it sounded in a mix, or if it was clipping in your DAW. If you keep it at 0db with your Stranderg, and you like the tone of it recorded, and it doesnt clip...then just go with it. If you dont like the sound of it recorded, adjust it. I actually like running my input kinda hot.
 

Skippzore

Member
Sorry Dude, It looks like you already figured out the latency issues. As far as the distorting, you say your ibanez DOESNT give you that distortion? You dont have access to another guitar do you? to eliminate the possibility of the pick ups?
No probs.

Well... I went back and tried it again. (I'll update my main post too)

The problem is actually still present on my Ibanez RGA121! Dunno how I didn't pick it up the first time. Here's me strumming some chords at moderate attack. First 6db, then 0db. VOLUME WARNING!




The problem is (sort of...?) still present on my telecaster with passive pickups. A lot less noticeable, but when I really play hard you can tell.

Here is my ASIO setting in the driver, I'm using Cakewalk, try disabling your laptops onboard audio card in the bios.


View attachment 84241
View attachment 84242
Here is the settings in CW
View attachment 84243

I have everything set up similar to yours, except I have lower buffer sizes since 128 works just fine for me.
I highly doubt disabling my onboard sound card would do anything at all since it's not being used while recording, and that honestly seems like too much of a hassle since I use the onboard card all the time while I'm not using Reaper. I could try it but I won't do that just yet. I had the same issue with the latency on another computer (which was a decent gaming desktop) so hence my doubts.
 
I just wanted to potentially help with the latency issue. My first comment is that you refer to your computer as a "high end gaming laptop" which implies a good CPU/GPU combination with significant RAM and performant SSD (all great) BUT none of these things will significantly impact low latency audio if high ISRs (Interrupted Service Routines) and DPCs (Deferred Procedure Calls) latencies prevent your CPU from actually processing the audio. In my experience (a little over 37 years in software/hardware design & implementation), achieving low latency audio is more often a product of the BIOS and driver (for all the attached/included devices) implementations. A single poorly implemented (enabled) driver for pretty much anything in or attached to your laptop could be your culprit. Start by running LatencyMon (free open source) - this should give you a pretty good indication if you have a DPC or ISR problem. If you do, then through a simple process of elimination (disabling device drivers one at a time) can usually help find the culprit (if there is one). Unfortunately, if the problem is in the BIOS or driver for critical hardware then your recourse is limited other than making sure you're up to date with all patches. BTW: It can be a bad a idea to have more than one audio interface enabled if you're trying to achieve low latency audio - it is a simple matter (only takes a few seconds) to disable the devices not currently being used and then re-enable them when needed.

Hope this helps.
 

Skippzore

Member
I just wanted to potentially help with the latency issue. My first comment is that you refer to your computer as a "high end gaming laptop" which implies a good CPU/GPU combination with significant RAM and performant SSD (all great) BUT none of these things will significantly impact low latency audio if high ISRs (Interrupted Service Routines) and DPCs (Deferred Procedure Calls) latencies prevent your CPU from actually processing the audio. In my experience (a little over 37 years in software/hardware design & implementation), achieving low latency audio is more often a product of the BIOS and driver (for all the attached/included devices) implementations. A single poorly implemented (enabled) driver for pretty much anything in or attached to your laptop could be your culprit. Start by running LatencyMon (free open source) - this should give you a pretty good indication if you have a DPC or ISR problem. If you do, then through a simple process of elimination (disabling device drivers one at a time) can usually help find the culprit (if there is one). Unfortunately, if the problem is in the BIOS or driver for critical hardware then your recourse is limited other than making sure you're up to date with all patches. BTW: It can be a bad a idea to have more than one audio interface enabled if you're trying to achieve low latency audio - it is a simple matter (only takes a few seconds) to disable the devices not currently being used and then re-enable them when needed.

Hope this helps.

Oh, thanks, this was very helpful and educating, I didn't know these things. The BIOS on these laptops are usually kinda crappy, so it wouldn't surprise me.
At first LatencyMon said everything seemed fine. After a while of monitoring (a few minutes) it said I might have some issues due to power management and CPU throttling, which might cause crackles and pops. I do use a CPU throttling software to keep the device cool but I usually have it setup to high performance while running Reaper. Seems like turning the throttling off keeps LatencyMon in the green instead. Doesn't seem like that should be what's causing the delay though? It didn't change anything in regards to the latency I'm actually experiencing when I turned the throttling off.

To disable other audio interfaces, would I just disable them in the sound control panel? Or elsewhere?


On a side note: While recording through a Focusrite Scarlett 2i2 without the manual offset latency of 2207, everything is just fine and dandy. No delay whatsoever. Dunno if that proves something regarding the capabilities of the computer.

I'd rather not hook up the FM3 to the Focusrite unless I REALLY have to. Feels like such a hassle and quite frankly a bit dissapointing considering what the FM3 is in comparison to the Focusrite.
 

GlennO

Fractal Fanatic
Used the above video and ended up at a WHOPPING +2207 samples to compensate for the lag. This is with 48khz/128 samples. Been trying to fix it by going to lower sample values but at 64 and down I've been noticing audio artifacts, so 128 samples + latency compensation seemed like my best bet.
This has been reported many times on the forum. You'll have to check with Fractal Audio to learn the status of the issue. You probably know this, but the problem isn't the latency. All interfaces have latency. It's best to monitor direct anyway, so latency is generally irrelevant. The problem is the reported value of the latency is wrong. This causes the DAW to misalign the recorded audio. The only solution is to manually set the latency in the DAW preferences.
 

Skippzore

Member
This has been reported many times on the forum. You'll have to check with Fractal Audio to learn the status of the issue. You probably know this, but the problem isn't the latency. All interfaces have latency. It's best to monitor direct anyway, so latency is generally irrelevant. The problem is the reported value of the latency is wrong. This causes the DAW to misalign the recorded audio. The only solution is to manually set the latency in the DAW preferences.

Yeah I just hoped there was some smarter solution or something, since more people weren't talking about it. With an issue like this you'd think every single person who uses the FM3 for recording would be complaining A LOT. Thanks.
 

GlennO

Fractal Fanatic
It's a popular topic on the forum, so I'd say a lot of people are talking about it. In any case, every single person who records the FM3 (and the AxeFX III) is probably manually setting that preference in their DAW, especially if they have the usb buffer size turned all the way up like you do. Either that or they gave up and connected it to an audio interface that doesn't have this problem :).
 

Skippzore

Member
It's a popular topic on the forum, so I'd say a lot of people are talking about it. In any case, every single person who records the FM3 (and the AxeFX III) is probably manually setting that preference in their DAW, especially if they have the usb buffer size turned all the way up like you do. Either that or they gave up and connected it to an audio interface that doesn't have this problem :).
Does having 128 as buffer size count as having it "turned all the way up"? I thought 128 was at most like average, on the verge of being kinda low?
 

GlennO

Fractal Fanatic
I'm referring to the usb buffer setting on the AxeFX III, but maybe you're referring to the DAW audio buffer size. Now that I think about, I don't think the FM3 has that setting for some reason.
 

Skippzore

Member
I'm referring to the usb buffer setting on the AxeFX III, but maybe you're referring to the DAW audio buffer size. Now that I think about, I don't think the FM3 has that setting for some reason.

Oh! Yeah, I'm talking about the DAW buffer. I don't think the FM3 has a buffer setting. I can just set a Preferred ASIO Buffer Size in the FM3 USB Audio Device Control Panel on my computer. It's set to 128 samples.
 
Top Bottom