[fixed] FC12 PROBLEM (& FC6)....3 BUTTONS (ALL BUTTONS) not functioning..but light up.

I am having lock up issues with the FM3 and I recently added the FC6 and it's also acting the same as mentioned in this thread. Anyone figure this out?
No, but... I get different behavior with different XLR cables. Starting to think it really is the cables, but I have spent a lot of $ on new cables to have the same exact issue.
I'm having a similar issue with my FC-6. One switch will get stuck in the "on" position. This freeze happens across several different Presets, all of which are running well under the CPU limit. Sometimes a switch will lock up in the bottom row and let me engage a switch in the top row. But then I can't get back down to engage a switch the bottom row. I hired a Fractal expert to go through my entire FM3/FC-6 setup to make sure everything has been programmed properly so it's not a setup error on my end.

And this is the second FC-6 unit that's doing this same thing. I sent one back to Fractal and they sent me this new unit. Same issue. I have an email in to support to see what to do next. So frustrating.

You can view a video of my issue in the link below. Anyone have a solution? Thanks!

FC-6 Switch Freeze
Unfortunately no solution here. Everyone says try different cables which may work for awhile but the problem eventually returns for me. Although support has been extremely willing to help, I'm very frustrated with the lack of a solution.
Yeah, I've tried troubleshooting it in every way possible. At least I know it's not a hardware issue as this is my second brand new FC-6. Tried many different cables as recommended. I also use a Furman Power Conditioner to rule out any dirty power issues. Support has been totally on top of the issue and I know they are trying to come up with a solution. Hopefully there is finally a fix and soon. Can't get through a rehearsal without this locking up several times. Couldn't trust it for gigging. I sold everything from my previous live rig to get these Fractal units. The FM3 is absolutely amazing. Love the sounds and endless combinations. They nailed all that. But this is a deal killer if switching locks up.

I wonder if the FM9 will be a better choice as it's all one unit and doesn't rely on a separate cable connected unit that is powered from the FM3 like the FC-6 requires?
I did a gig last week and had it lock up 6 times. At home the next day I left it on for hours and couldn't get it to lock up. So weird. I also had a rehearsal with it since then and no problem there either.
I did a gig last week and had it lock up 6 times. At home the next day I left it on for hours and couldn't get it to lock up. So weird. I also had a rehearsal with it since then and no problem there either.
I have ongoing communication going with Fractal support on this. I'll post again once I get the latest response to whatever the fix could be.
I just updated the firmware on my FC6. Locked up on me 3 times within 1 hour which it never did before. 1st 2 times I rebooted my FM3. The 3rd time I just pulled the cable out of the FC6 and plugged it back in. Recovered ok. Going to see if I can get a copy of the previous firmware and roll it back. Hopefully that’s all it is and not something going out.
There is a lockup issue in 19.01 its happened a few times to me as well. Cliff said its been fixed for 19.02 but that has its own issues. Hoping for 19.03 tomorrow. Not exactly FC related but I think it was changing scenes on the FC where the lockup takes place.
Have you heard anything back on this yet? My FC-6 is getting power but not control. Very frustrating as I had to send the AxeFX back for a replacement DSP board, and now the foot controller isn't being recognized by the rack unit. I'd update the FC-6 firmware but the AxeFX doesn't even see it connected...
Still waiting on a solution. Fractal plans to have me send back both my FM3 and FC-6 to troubleshoot further. Like other users have posted, I also have "random" lockup issues. I'll have a day where the FC-6 doesn't lock up or only does it once across an entire rehearsal. Or I'll have a night like last night where it literally locked up on every single song. I have to power down and power back up. Can't possibly use the rig this way. The randomness of the lockups has got to be a major factor in the difficulty with troubleshooting. I just keep trying to give the nice folks at Fractal as much detailed info as possible so they can find a permanent fix for everyone.

Here's just one of my FC-6 "freeze" moments...

FC-6 Switch Freeze
More strange behavior on the FC6 and FM3. Running the OMG9 setup. Pressed hold on the effects switch. The FC6 went to the looper layout. But all lights turned off on the FC. Looper layout text normal. Pressed the right FM3 switch which should go to the effects layout on the FC6. It did that but the right switch on the FM3 text said looper. And the inverted display on only that switch reverted back to normal. The other 8 still inverted.

Another incident was I selected the looper layout, the FC6 showed looper view. But the FM3 went to the tuner. It locked up and switches didn’t respond. Had to reboot.

I tried to get some pics but the text wouldn’t show on my phone camera. I figure there are ways around that but was busy playing.

It’s consistently screwing up on me now so I’ll try to write the details down next time.

FC6 firmware 1.12
FM3 5.01

Here’s a pic of the ‘selecting the looper and getting the tuner’. Can’t see the text but you can see the rightmost effects layout switch is bright.


  • 05B0F1CD-B3FE-4633-B42B-6B700C0F1D56.jpeg
    501.9 KB · Views: 7
Last edited:
Same problem here, effects page is frozen, i have 3 shows to come, one yesterday and i had to use Scenes and i never used, it was a nightmare, hope that comes an emergency update.
I’ve been having a similar issue recently. I noticed that whenever I held down the top right button on my fc-12 it would lock up the top right 3 buttons and they would become unresponsive. Everything else continued to work. If I rebooted my axe fx or fc12 the buttons would work until I held down the top right button, then the top right 3 would become unresponsive again. I had the hold function of the top right button set to bring up the tuner. I removed that hold function to bring up the tuner for the top right footswitch and set it for the top left footswitch. I had no issues using that in a show that I played last night

I even took the fc-12 apart before the show to make sure all the ribbon cables were seated. There was one that appeared to not be completely seated. After reseating that cable I was still getting the same issue. Is there a reason there is no clip or retention on these cables? I had a similar issue with my axe-fx 3 where the ribbon cable to the front input board was loose and needed to be reseated. Anyways…

It’s tough to diagnose because this issue seems to be sporadic. I do have a workaround to move the tuner function to holding down the top left footswitch.

I was reading that the faslink connection is more prone to interference. I purchased new cables and I am using canare l4s with amphenol xlr connectors. And I have tried other xlr cables and verified it happened with all of them.

In the meantime, it looks like my issue was resolved by upgrading to 19.02. I have been testing it throughout the day today. My fc-12 has been at 1.12 this whole time. I would recommend updating your axe fx firmware. Good luck! I’ll be keeping an eye on this thread going forward as well!
No dice for me - 19.02 actually made the problem worse. now instead of 3 buttons freezing, I have 6 buttons freezing. How are the "pros" actually using this during a live performance?
Yesterday I played for an hour or so. Running the OMG9 on the FM3/FC6. Doing scene changes and effects. The FM3 layout got stuck in the effects layout while switching back and forth from scenes to effects. I just put it back to layout 8 on the editor. That was a new one for me. No other issues. I used to have occasional glitches but since the 5.01 it’s been weird. I’m hoping it’s being addressed.
I use OMG 9 with my FM3/FC6 and usually the effects page has a problem with freezing but it has happened in scenes too. I wonder if switching to a custom layout would make any difference? I doubt it.
Hi guys, any update on this? I'm having the unresponsive button problem on both of my FC-12's.
My AxeFX 3 and the FC 12's are on the latest firmware.
So after a few months of no issues I’ve had it happen twice since I upgraded to 20.02. Coincidence? Very random and frustrating.
Top Bottom