• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

help! whammy woes!

I've searched and read through a lot of the whammy posts here and still can't seem to figure it out..

I have my midiboard setup properly one switch activates the wah, another activates the whammy, perfect.

The issue is my whammy when using the expression pedal goes from heel down (nothing) to toe down (2 octaves up) with nothing inbetween. I want to be able to sweep UP to the 2 octaves so I can hear the gliding through and other pitches.

I've read http://forum.fractalaudio.com/axe-fx-ii-discussion/72433-how-bring-whammy-without-auto-engage.html

and many others but for some reason can't get it right.

The farthest I've gone so far is, I've gotten the sweep going on, but only via the control parameter's source set to external 1 and auto engage on fast position. This works, but is of course auto engaged and thus inteferes with the wah if I turned the wah on. OR, if I turned on my switch I setup for the whammy, the auto engage is actually turned off and therefore disables the whammy when I rock the expression pedal. I want the opposite of all this!
eg: whammy on when i hit the switch, and it glides up to 2 octaves, where you can hear the full sweep! whammy off when i hit the switch again to turn off! classic pedalboard style.

Can someone please tell an axe fx noob like me how to get this sorted? Thanks in advance!
 

Bodde

Fractal Fanatic
It's raining Whammy topics!

Not exactly sure what you mean but one way of having both wah and whammy under one ep pedal is using scenes. Use scene 1 for whammy and scene 2 for wah. There is another way of having programmed an IA switch to both wah and whammy bypass but I never use this. Third option is to use the ep to bypass a block. I prefer this to auto engage. There might be more options that I am not aware of. Better yet; use two ep's!
 

Noriuky73

Power User
If I understand your explanation .... you need to save the whammy as off ...
I didn't get your problem ... you use only one pedal ? or you have no luck setting your whammy with a different controller than external1 ?
wich kind of pedalboard you use ? You use a wah in the same patch ? you need it even at the same time ?

It can be a problem of routing of the patch and it can be a problem of routing of the controllers and your pedalboard settings ... it dipends

if you need 2 FX in the same patch WITH autoengage functions (WAH and WHAMMY for ex. ) and you have only one EP the easiest way to have everything under control is to split the signal in 2 rows with Wah and Whammy suitetd by a Filter Block ( Each ) and manage the signal routing with the bypass status of the filters ... so you can have the Wah or whammy in the signal both bypassed or engaged (your choice) per scene ...

If you need something particular with the Whammy ... as engaging it directly 2 octaves up f.e. ... then you need to edit the start status of your EXT PED on your pedalboard ... I made it with mine for the wah , I like the auto engage with the Off at 95% so I told to my MFC that the ExtPEd for WAh ( always my EP1 ) to start at 100% A.k.a. 127 in Midi CCs when I recall this patch . In this way my wah is always desengaged when I recall the patch ( even if it is not at 100% position ) until I start to move it !!

Hope this helps ... sorry for my noob english :)
 
What I want is very simple
i have a scene and within that scene I have 2 effects, a wah and a whammy, both of which work and turn on via seperate switches on my midiboard. Which is how I want it.
The only issue is when I use the whammy, there's no swep, no range. It's set in axe edit to go up to 2 octaves, but when I switch it on and rock the expression pedal, it goes from nothing to the full 2 octaves, and nothing in between. I want the full range to be heard when I rock the pedal from heel down to toe down I want to hear all the other ranges while it goes up to the 2 octaves.

I believe it's just something I need to change in the control parameter of the whammy but I'm not sure what.

I don't want any auto engage for anything btw.
 

simeon

Axe-Master
have you attached the pedal to bypass instead of control? it sounds like the pedal is actually bypassing the effect
 

mjlongo

Member
This is a pretty good youtube video for setting up expression pedals: https://www.youtube.com/watch?v=vip2op6TWkc

Around the 23:30 mark he talks about calibrating a pedal.

Also here in the wiki there is talk about setting up a whammy pedal: Pitch effect - Axe-Fx II Wiki

From that page:
Put a Pitch block in line, set to Classic Whammy. Source = Global. Bypass Mode = Thru.
Assign the Control parameter to your pedal's external controller.
Assign the same external controller to the Mix parameter. Set Mix at zero. Modifier menu: Start 40, Mid 100, End 55, Slope 0, Scale 10, Offset 100.
Make sure the Pitch block is engaged and save the preset.

There is a link in that page for controllers and getting the pedals to work correctly: Controllers and modifiers - Axe-Fx II Wiki

It sounds to me like your expression pedal was not calibrated.
 
have you attached the pedal to bypass instead of control? it sounds like the pedal is actually bypassing the effect

that sounds like it, how do i reverse this?

mjlongo, i've tried the wiki axe fx II settings and nothing works UNLESS i turn on auto engage in which case it will turn on but of course, once i hit my switch to activate, it turns off, doing the reverse of what I want.

I'm not using an MFC so the youtube vid didn't help too much, but it's calibrated, as the wah sounds fine.
 
Top Bottom