• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

[solved] Filter block won't un-bypass in Axe-Fx III if Envelope Follower used

I'm new to using the Forum, so please excuse me if this isn't the right place or format.

I have been a happy AXE FX II user for many years, and have just received the truly awesome AXE FXIII. Have only just started exploring it, but have hit a snag when using a Filter block.

The background is I built a patch in my AXE FX II to get an approximation of the Clavinet sound for Stevie Wonder's Superstition. It worked extremely well on the FXII, but I can't get it to work on the FX III.

First, I used FracTool (thanks Al Grenadine) to transfer the preset over from the II to the III - had no issue with other presets apart from the need to fix output level and balance, and Amp blocks seem to be different on some presets (haven't really looked at that yet though).

For my Superstition preset however, the Filter block was in a Bypass state in the FXIII, even though it was Engaged in the FXII. No matter what I do, I can't get it to Engage, UNLESS I turn off the Envelope Follower as the Source controller for Frequency and Q. But then of course I don't get the desired sound.

I tried recreating the Filter block from scratch, but have the same issue as soon as I assign the Sources to Evnelope followe for either Frequency or Q.

Does anyone know how to fix this?
 

Admin M@

Administrator
Fractal Audio Systems
Moderator
I second the suggestion that Auto-Engage should be set to NONE when using Envelope as a modifier source.
 
Can't try it right now since I'm not at my studio, but are you by chance turning on auto-engage when you're assigning the modifiers?
I second the suggestion that Auto-Engage should be set to NONE when using Envelope as a modifier source.
Thank you both for the rapid suggestions! The Auto-Engae was indeed on for both the Frequency and the Q, becuase it was set that way in my FXii patch and worked well.

I went back into the block in the FXiii and turned the Auto-Engage to Off in both places, and Voila - I can now Engage the Filter Block, so one problem fixed (although I don't know why it would behave so differently between the FXII and III, but that's secondary).

Unfortunately I'm finding that all the pre-sets I transeref over are sounding like crap, even when I fix the Amp and Cab blocks, so I'm abandoning them a making new ones staring from some of the factory Presets (which sound awesome).

At least I should be able to make the Filter Block work like it should, thanks to your advice.

Many Thanks,
Mike
 

unix-guy

Legend!
Thank you both for the rapid suggestions! The Auto-Engae was indeed on for both the Frequency and the Q, becuase it was set that way in my FXii patch and worked well.
You can not manually enable or bypass a block when it has an auto-engage modifier on the Axe Fx II or III...
 

666was999

Forum Addict
You also should retweak the envelope settings in the III. Since the input volume is different in the III you don't get the same impact from the signal compared to the II. IiRC you need to lower threshold and/or raise gain a bit in the III's envelope settings.
 
You can not manually enable or bypass a block when it has an auto-engage modifier on the Axe Fx II or III...
You also should retweak the envelope settings in the III. Since the input volume is different in the III you don't get the same impact from the signal compared to the II. IiRC you need to lower threshold and/or raise gain a bit in the III's envelope settings.
Thanks for the helpful advice! Haven't had a chance to work on this for the past few days, but am about to get to it.

Just a clarification on unix-guy's response - on my AXE FX II I was using the Filter block with Autoengage "on" for both Frequency and Q, with no problems at all. Maybe I'm missing something else that was set differently, but it definitely wasn't that. Took some screen shots that might help illustrate thisScreen Shot 2019-05-10 at 3.00.20 PM.pngScreen Shot 2019-05-10 at 3.01.05 PM.png
 
Have been trying different adjustments - so far I can't get anywhere near the same effect the Filter block gave me on the FXII. I remain unconvinced that the Autoengage issue for the Filter block isn't a big part of the difference, but maybe I'm just an idiot.

For the record, I wound up with a great Superstition sound on the FX II that I (so far at least) can't replicate on the FXIII (due to the Filter block issue I suspect). Will keep playing with different alternatives and update this thread as I learn more.
 

unix-guy

Legend!
Thanks for the helpful advice! Haven't had a chance to work on this for the past few days, but am about to get to it.

Just a clarification on unix-guy's response - on my AXE FX II I was using the Filter block with Autoengage "on" for both Frequency and Q, with no problems at all. Maybe I'm missing something else that was set differently, but it definitely wasn't that. Took some screen shots that might help illustrate thisView attachment 54986View attachment 54987
What I was saying is that if you have auto-engage ON you lose the ability to manually engage or bypass the block.

Also, you really only want auto-engage on a single modifier within a given block. More than 1 doesn't make sense, especially if they have different settings (like yours).
 
What I was saying is that if you have auto-engage ON you lose the ability to manually engage or bypass the block.
Ah. Sorry man, mis-understood what you were saying.

Still, there seems to be something quite different in behaviour going on between the II and the III. I don't have my II with me to confirm what I'm about to say, but at the very least the II did not put the Filter block into the Bypass state when the Envelope Follower had Auto Engage on, whereas on the III it definitely puts the Filter block into the Bypass State under such conditions.

I also agree in principle with what you said about not having auto engage on more than 1 modifier, but in that particular case it seemed to work. I don't remember how I got to that point when I set up the preset (I started with suggestions from another user and tweaked from there), but in the end the "pseudo-Clavinet" sound was really, really good. Haven't managed to come close yet on the III, but having said that haven't had much time to work on it.

Anyway, I'm sure I'll figure it out eventually. If anyone knows of a good "Superstition" sound having been achieved on the III, please point me in the right direction.

Thanks again to all for the efforts to help me.
 

unix-guy

Legend!
Ah. Sorry man, mis-understood what you were saying.

Still, there seems to be something quite different in behaviour going on between the II and the III. I don't have my II with me to confirm what I'm about to say, but at the very least the II did not put the Filter block into the Bypass state when the Envelope Follower had Auto Engage on, whereas on the III it definitely puts the Filter block into the Bypass State under such conditions.

I also agree in principle with what you said about not having auto engage on more than 1 modifier, but in that particular case it seemed to work. I don't remember how I got to that point when I set up the preset (I started with suggestions from another user and tweaked from there), but in the end the "pseudo-Clavinet" sound was really, really good. Haven't managed to come close yet on the III, but having said that haven't had much time to work on it.

Anyway, I'm sure I'll figure it out eventually. If anyone knows of a good "Superstition" sound having been achieved on the III, please point me in the right direction.

Thanks again to all for the efforts to help me.
Possibly the II didn't do the right thing because of the double modifier?

In any case, I do know there was a somewhat recent change to the Envelope Controller on the Axe Fx III. I don't know if that change made it different from the II or not...

As far as wizardry with this kind of stuff, usually @simeon, @Bakerman or @yek will drop some wisdom.

Also, @Moke comes up with some crafty solutions, too.

Maybe one will come to your rescue?
 
Have done more playing around, and realized I may in fact have stated the "problem" incorrectly.

When I look back at the mapping of my AXE FX II preset using FracTool, it also shows the Filter block is normally in Bypass mode. The Bypass mode itself is Mute. However, when I play a note, I get sound, so presumably the AutoEngage is kicking in to take it out of Bypass.

On the FX3 however, this doesn't work. Early on when I got no sound from the preset I had changed the Bypass mode for the Filter block to Thru, to get some sound but without the Filter effect. With the Filter block Bypass set to Mute, the preset won't provide any sound at all, even with AutoEngage set on for the Filter block. However, with AutoEngage set to Off, while I can get the Filter block to manually Engage, it doesn't vary the tone with pick attack even with the Envelope Follower as the Source (it will with Pitch Follower, but its not the same quality of sound).

Sorry this is so confusing... Will keep playing with it and once I get it solved will post an update.
 
So I played around a bit more - can't seem to get the Envelope Follower to do anything, and I don't understand enough about how they work to do anything intelligent.

I did swicth over to the Pitch Follower as a Source for Frequency and started tweaking the Slope, Scale, and Offset parameters, and its giving me some sounds that are starting to move in the direction of what I'm looking for at least. Seems to also work for the Q to some degree as well (also played a bit with LFO 1 as a Source on Q).

Won't get there tonight though, time to pack it in.

Will post an update if and when I achieve sonic nirvana.
 

Bakerman

Axe-Master
Check the envelope controller settings in the controllers menu with LFOs etc. No movement would indicate either threshold set too high, or unused input as envelope source (it can respond to Input 1 or 2).
 
Check the envelope controller settings in the controllers menu with LFOs etc. No movement would indicate either threshold set too high, or unused input as envelope source (it can respond to Input 1 or 2).
I noticed last night that there was no movement of the dot on the Envelope graph. I did try playing with various parameters, but not sure if I changed the Threshold much. Where do I find the Source used by the Envelope Follower?
 

Bakerman

Axe-Master
Are you looking at the actual envelope page in the controllers menu? Not the filter modifier dot/graph. Click "Controllers" near top-left of Axe-Edit III, or access w/ knob click from front panel home screen.
 
Are you looking at the actual envelope page in the controllers menu? Not the filter modifier dot/graph. Click "Controllers" near top-left of Axe-Edit III, or access w/ knob click from front panel home screen.
I was looking at the filter modifier dot/graph.

I have not had the occasion to ever use the controllers menu before, but thanks to your post I will find it and try it later tonight!

Thank-you very much, with everyone’s advice I’m starting to feel like I’m finally on the right path (I hope I didn’t just jinx myself LOL).
 
SUCCESS!!!!

I went into the Controllers menu and reduced the Threshold as suggested by Bakerman, and suddenly (finally!!!) the AutoEngage worked. Still had no sound on my original translated patch, but that was because the Output 1 Level translated across to minimum with FracTool, and Balance was hard left (was the same in all my translated patches). Tweaked them to 0 dB and 0 Balance and then there was sound, but with a lot of distortion. Checked the Input 1 level, and it was WAY high. Put it back to 0 bB and eureka, the basic sound of my preset is there. Think I still have to tweak Amp and maybe Cab blocks, but the fundamental issue (Envelope Follower engagement in the Filter Block) seems to be solved.

If any of you who helped are in Montreal this summer (great place to be by the way; Formula 1, Jazz Festival, Blue festival, Comedy Festival, beautiful people, etc...), I will buy you a drink or 10.
 
Also, for posterity; AutoEngage was set per the screenshots I included in earlier posts, both for Frequency and Q, and left untouched.

If anyone is interested attached is a copy of my Superstition preset for the FXIII (translated from the II, with the tweaks mentioned in the previous post).
 

Attachments

Bakerman

Axe-Master
In this example the fast position autoengage setting would be the first to switch the block on/off. The other one wouldn't really do anything.

Autoengage just engages or bypasses the block based on the controller value. If you don't want the filter to bypass/mute during low input levels, disable autoengage.
 
Top Bottom