• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Axe-Edit under Wine, do we need an ALSA setup?

gootah333

Inspired
I'm trying another attempt at running AxeEdit on Linux using Wine. The version 1.06 of the USB Linux driver was successfully installed. AxedEdit runs, but it is showing "Not Connected" for the AxeFxII.

A poster, who only ever made 1 post on this site, mentioned something about needing to preconfigure ALSA & MIDI in order to get AxeEdit to work.

Anyone know how to do that?
 

unix-guy

Legend!
I'm trying another attempt at running AxeEdit on Linux using Wine. The version 1.06 of the USB Linux driver was successfully installed. AxedEdit runs, but it is showing "Not Connected" for the AxeFxII.

A poster, who only ever made 1 post on this site, mentioned something about needing to preconfigure ALSA & MIDI in order to get AxeEdit to work.

Anyone know how to do that?
I'm not sure why it would as ALSA is for audio and there is no audio component in Axe-Edit...

Tagging @AlbertA - I know he does a lot of Fractal on Linux.
 

Sully

New Member
HI

I've just switch to Linux Mint 19.1 (x64) Cinnamon from Windows 2010 (Cant stand the W.2010 Bloatware and lack of process control etc...).

I'm a total Linux noob, but after getting to grips with the terminal and a few commands I've managed to get everything I need out of Mint to make a permanent switch to Linux from Win10. I've managed to get Wine installed & running also.

Fractal Bot in Mint picks up my Axe Fx 2XL & I can get Axe Edit to launch, but Axe Edit does NOT connect to the Axe Fx - it stays disconnected.

I've installed the aalbaguirre PPAs etc...

Every-time I try to run the Fractal Audio Driver.exe using WINE I get 'Driver Install Error Code: 105'

I've also tried installing axfx2setup.sh (run in terminal) with no luck...

Its the only issue that's breaking my heart here! - So far Linux is a way better option than windows 10 as far as I'm concerned

Any suggestions much appreciated...
tnx
 

AlbertA

Fractal Fanatic
Did you install the packages in my PPA?

You won’t be able to install the driver through wine, FYI.
 

volt

Inspired
AlbertA is right: Don't (try to) install the Windows driver. This won't work on Linux and is not needed.

HI
...
I've also tried installing axfx2setup.sh (run in terminal) with no luck...
....
Did you run the script (axefx2setup.sh) as root?
Did you see any errors? If so please post them or pm me.
Also: What version of the script do you have?

For using Axe-Edit you only need the Axe-Fx working as a USB-to-MIDI interface. You can test if the Axe-Fx works as a MIDI interface as described here.

Not related to Axe-Edit but just in case you should be interested in using the Axe-Fx as an audio interface, too, you can test audio functionality like this:

a) for playing back a stereo audio file *recorded with 48kHz 24bit*:
Code:
aplay -D hw:x,0 path_to_your_playback
b) for recording a *4 channel* (stereo wet and stereo dry channels from the Axe-Fx II) audio file:
Code:
arecord -D hw:x,0 -d 10 -c 4 -f S24_3LE -r 48000 hw:x,0 path_to_your_recording
The "x" after "hw:" has to be substituted with the sound card number your Axe-Fx II has gotten.
 

Sully

New Member
HI volt,

Thanks for the response & info!


Did you run the script (axefx2setup.sh) as root?
Did you see any errors? If so please post them or pm me.


Yes I've run axefx2setup.sh as root and received the following :
'A udev rule for the Fractal Audio Systems Axe-FX II is already present in /etc/udev/rules.d/55-fractalaudio.rules. This rule has neither been modified nor checked by this script. Please make sure the existing rule is working properly.

Installation finished. Press any key...


Also: What version of the script do you have?
Axe-Fx_II_USB_Driver_Setup_Linux_103


When I run the commands to test audio functionality I keep getting the following message : root:could not open file '/etc/apt/sources.list'

Thanks again!
 

Sully

New Member
Did you install the packages in my PPA?

You won’t be able to install the driver through wine, FYI.
Thanks for the response AlbertA!

Yes trying to run the driver via wine is prob a noob move, but I'm just trying everything...

Yes I installed the packages (See Image)
Screenshot PPAs.png
 

volt

Inspired
HI volt,
Yes I've run axefx2setup.sh as root and received the following :
'A udev rule for the Fractal Audio Systems Axe-FX II is already present in /etc/udev/rules.d/55-fractalaudio.rules. This rule has neither been modified nor checked by this script. Please make sure the existing rule is working properly.

Installation finished. Press any key...
Ok, this message appears if the file "55-fractalaudio.rules" has already been installed, probably by running axe2setup.sh before. Could you please post the content of "55-fractalaudio.rules"? You can post the output of
Code:
cat /etc/udev/rules.d/55-fractalaudio.rules
Please post the output of
Code:
whereis -b fxload
Also I would like to have a look at the directory "/usr/share/usb/FractalAudio/axefx2". Just post the output of
Code:
ls -al /usr/share/usb/FractalAudio/axefx2
Also: What version of the script do you have?
Axe-Fx_II_USB_Driver_Setup_Linux_103
Latest version is 1.06 but that shouldn't matter.
When I run the commands to test audio functionality I keep getting the following message : root:could not open file '/etc/apt/sources.list'
Please post the commands you ran in detail.
 
Last edited:

AlbertA

Fractal Fanatic
Thanks for the response AlbertA!

Yes trying to run the driver via wine is prob a noob move, but I'm just trying everything...

Yes I installed the packages (See Image)
View attachment 52502
Once you have the PPA installed (as shown there) you still have to install the actual packages you need. In your case, all you need is the " axefx2-usb-firmware" (sudo apt install axefx2-usb-firmware)
 

volt

Inspired
@Sully Maybe one thing to make clear: You don't have to use axefx2setp.sh and AlbertA's packages. Both have the same aim but they install the necessary .hex and .rules files with different names in (partly) different locations. I would recommend to use only one method. If you opt for AlbertA's packages run
Code:
axefx2setup.sh -u
in order to remove the files and folders created by running axefx2setup.sh.
 

Sully

New Member
It's Finally Working!!!

@volt and @AlbertA - Thank you guys so much! - You are legends.

I'm not sure which Installation process worked in the end. I was so confused after installing & reinstalling over and over.
I've saved all the files and code you guys provided so that I can retrace my steps and figure it out clearly again later.

I believe that once I installed axefx2sept.sh as root and ran (sudo apt install axefx2-usb-firmware) it was actually working fine, it wasn't until I went into the AxeEdit settings and configured the correct Ports that the devices connected. Im running the AxeFX into my Audio Interface (Edirol UA1000).

Next step will be to try @volt instructions for using the Axe-Fx as an audio interface and learning the differences between the various Linux audio Devices/Drivers (Jack,alsa etc...) for use with Reaper DAW

Bye Bye Windows 10.

Thanks!
 

Sully

New Member
@Sully Maybe one thing to make clear: You don't have to use axefx2setp.sh and AlbertA's packages. Both have the same aim but they install the necessary .hex and .rules files with different names in (partly) different locations. I would recommend to use only one method. If you opt for AlbertA's packages run
Code:
axefx2setup.sh -u
in order to remove the files and folders created by running axefx2setup.sh.
Awesome:)
 

bstaley

Inspired
I hope you guys can help me. I'm making another attempt to move away from Windows 10. I've tried searching the forums and I'm not having much luck.

I have an Axe-FX III. I'm running Linux Mint 19.2 with the 4.18.0-25 kernel. I have installed Wine 4.0. The Axe3 is detected fine by Linux and shows up as a sound device. I use Wine to install both FractalBot and Axe Edit. It seems to work successfully. Both of the applications will open up and run for about 30 seconds and then they crash. Also, the mouse cursor does not show up in Axe Edit. There's a pretty extensive error log, which I don't know if it would help you, or there is a known workaround.

Any help would be appreciated. I'd like to leave Windows once and for all. Thanks.
 
Top Bottom