• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

[Windows] USB overflow issue every time stream starts

AlbertA

Power User
In Windows 10, I made my Axe-Fx III the system speakers.

The USB Buffer Size in the Axe-Fx III itself is set to 8.

Go to Setup->Utilities->USB page.

After starting to play audio (say a Youtube video), you can see the OUT USB meter slowly crawls up. After about 2 minutes it the bar overflows (and resets to a lower level); some seconds later I hear distortion in the audio. It eventually recovers and never seems to happen again as long as the stream keeps playing. You see the IN USB bar stabilizes to a small bar eventually.

However, close the browser or Youtube tab. This should stop the USB stream after some seconds.

Open a new tab, replay the same video and the overflow pattern repeats again as described above.

It seems like every time the USB stream is restarted this happens.

It probably happens much slower with increased USB Buffer Size settings on the Axe-Fx III.

For completeness:
The FASUSBAudio Control panel Buffer settings are set to 256 samples, Safe mode checked.
USB Firmware in the Axe-Fx III is v 1.06
Axe-Fx III Firmware 1.08
 
Last edited:

volt

Inspired
Appreciating your efforts very much. So even though not using Windows: Many thanks for investigating!
 

illodin

Member
Not me, because I don't have the III yet (Europe...) but I hope FAS will fix it as I plan to use the III as a generic soundcard for my Windows PC as well.
 

AlbertA

Power User
This still happens with DSP Firmware 1.10.
Can anyone else confirm?

Steps:
  • In the Axe-Fx III, Go to Setup->I/O->Audio. Set USB Buffer Size to 8.
  • In your PC, go to the FASUSBAudio Control Panel, Choose 256 samples, Check safe mode.
  • Click the Speaker icon on the far bottom right, Select Speakers (Axe-Fx III)
  • In the Axe-Fx III, go to Setup->Utilities->USB. The OUT USB bar should be blank (meaning no audio is currently streaming). If not close any other audio, browser, etc until it goes blank.
  • Open up chrome, go to:
  • About the 2:14 second mark audio starts distorting, eventually recovers about the 2:35 mark.
 
Last edited:

FractalAudio

Administrator
Fractal Audio Systems
Moderator
If you are getting overflow or underflow that buffer size is too small for your computer. Increase it.
 

James Baker

Member
I replicated your steps and settings and could not reproduce it on my end. I checked out multiple other videos on YouTube as well. I don’t use chrome, however. I use vavaldi which is based on chromium. I also tried Edge. Just for shits, have you tried a different browser?
 

FractalAudio

Administrator
Fractal Audio Systems
Moderator
It recovers though and always happens around the same time, which is why I suspect this is a logic issue at the AxeFx side.
It recovers because the logic resets the buffer on overflow/underflow. I can only get 8 to work on my fastest machine with nothing else running. 16 works on all my machines except my Macbook which I have to use 64.
 
Top Bottom