• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Use Axe FX II as MIDI -> USB device for synth VSTi??

Hello,

Ive been searching the forum and google with no luck so far.

Is it possible to use the AXE FX II as a MIDI converter so that I can connect my synthesizer to my MAC and controller VSTi's while in REAPER?

What I've done so far:
- installed AxeFxII USB driver for MAC
- changed USB ADAPTER MODE on the Axe FX to ON (and I tried OFF).
- connected the synth (Synth Midi OUT->AxeFxII Midi IN)
-- When I press down on a key on the synth, I see the midi light turn green. So I know it's getting a signal.
- connected the AxeFxII to MAC via USB
-- Reaper does see the MIDI signal from the USB (listed in midi devices).
---- This is where it gets a bit weird though. Under the listing for MIDI input device it's listed as:
---- "Fractal Audio Systems - AXE-FX II - MIDI Out (and I have the mode set for enabled+control)
---- Under the output device it reads:
---- "Fractal Audio Systems - AXE-FX II - MIDI In (Enabled)
------ Should it be listed the other way around? Midi in for input and Midi out for output device?

I also selected which midi device to use on the midi instrument track in REAPER. The virtual keyboard produces sound but when I select the AxeFx Midi, nothing happens when I press a key down.

I feel like I'm either REALLY close or this just isn't possible with the AxeFxII.

Thanks for your help in advance!
 

mr_fender

Fractal Fanatic
Make sure you turn "Record Monitoring" on for the track (the little speaker icon on the track strip) to hear the soft synth. For Windows, Reaper shows MIDI input device as Axe FX II MIDI In and MIDI output device as Axe FX II MIDI Out on my system. It's possible they are just labelled differently in the Mac driver though. I'm able to use my cheap little MIDI keyboard with VSTi synths in Reaper through my XL with USB adapter mode on.
 

Poparad

Power User
Edit: Reading comprehension. I didn't catch that you're trying to pass a keyboard through the Axe, and not convert your guitar signal to MIDI.



And yes, it may seem backwards, but the "MIDI Out" from the Axe would route to the MIDI In of a device, and vice versa. Just like in the the real world when connecting any two physical MIDI devices together.
 
Last edited:
Make sure you turn "Record Monitoring" on for the track (the little speaker icon on the track strip) to hear the soft synth. For Windows, Reaper shows MIDI input device as Axe FX II MIDI In and MIDI output device as Axe FX II MIDI Out on my system. It's possible they are just labelled differently in the Mac driver though. I'm able to use my cheap little MIDI keyboard with VSTi synths in Reaper through my XL with USB adapter mode on.

I do often forget to turn monitoring on. Unfortunately, this time I didn't forget, monitoring is on and the signal still doesn't go through. The XL came out after the AxeFx II. I wonder if that makes a difference?
 
Well, I decided to see if I could get it working with my PC instead. It seems to be working better but I still have an issue:
NO MONITOR SOUND OUTPUT.

On my PC, Options/Preferences.../MIDI Devices:
---- Under input device it now reads:
---- "AXE-FX II - MIDI In (and I have the mode set for enabled+control)
---- Under the output device it reads:
---- "AXE-FX II - MIDI Out (Enabled)

So that seems to be correct. Why the MAC is backwards I do not know.

When press a key down on my synthesizer, I do get a signal running into REAPER! yay!

However...

I don't know how to direct the sound output to my computer's sound card. There doesn't seem to be a way to select it from the DEVICES "tab" in the preferences menu when you have the FAS USB DRIVER selected for your audio device. I'm not getting output to the monitors from even a MP3 dropped into reaper. I plugged in my speaker to the AxeFXII and nothing it coming out of that either.

On the MAC in the Device "tab" in REAPER you can select:
"Allow to select difference input and output devices" but I don't see that on the PC.

I tried using ASIO4ALL and either I'm not using it right or it's just not working.

Any ideas?
Thanks Again
 

simeon

Axe-Master
couldn't be bothered to scan the whole thread, but did you turn "usb adaptor mode" ON in I/O>midi?
 
Thanks Simeon, I just double checked that and yes "usb adapter mode" is ON.

Attempted to use "Playthrough" application = still no luck.

I believe I just need to figure out how to route the audio from REAPER out to my sound card.

My soundcard is a Soundblaster X-Fi Titanium Series.
Running this on Windows 7.
 
AH HA!

I went to the "Routing Matrix" in REAPER and selected SB X-Fi Synth A
Now the audio is going out to the Monitors! It is also working when I press a key down on the Synthesizer!
 
SOLVED!

Ok, so being NEW to this... there was certainly a margin for "human error" on my part.

I originally thought that you should have:
FAS USB Audio ASIO Driver selected for your ASIO DRIVER in order for this to work. WRONG!

The setup is:
- DEVICE settings "tab": Sound Card ASIO (in my case "Creative ASIO") selected as your ASIO DRIVER.
- MIDI DEVICES "tab": make sure that the AXE-FX MIDI IN & OUT are enabled.
- In the ROUTING MATRIX (in Reaper): (Make sure your preference pane is closed) you do not have to click under your sound card output as I thought before. Pretty much just leave it alone. I selected ALL MIDI Inputs under the VSTi track I had loaded.
- If something goes screwy (a weird latency issue, sustained/stuck keys, etc...) just delete the track and create a new Virtual Instrument Track.

So it works! The sound is outputting through my computer monitors AND I am using the synthesizer as my controller for the VSTi.

I suppose I learned something in the process and perhaps this will help someone in the future.

As for the Latency... click on the "ASIO Configuration" Button in the Device "tab" and push it down to 20ms. That just made a HUGE difference!!!! Woot! I don't feel any latency now.

Thanks for your help!
 
Last edited:

USMC_Trev

Fractal Fanatic
That last post in this thread was his last on this forum, so who knows if he'll get a notification email and respond.
 

lqdsnddist

Axe-Master
They have midi to USB convertor cables for like $5 on Ebay

Work great and as simple as plugging one end into your midi keyboard, the other into your usb port
 

Theurge

Member
Thanks. What I'm trying to do is while using the ethernet port for my MFC, and use the seven pin, and the phantom power, to connect another midi foot controller that controls MainStage/ableton live on a different midi channel. The idea is it saves using another midi interface. As my other pedal uses seven pin midi cables for phantom power, it would save on creating another way to power the other foot controller, either through using wall warts at the pedal board side, or buying one of those seven pin cables with the power connector 'off-shoot'. Their pretty pricey for what they are, and I feel uncomfortable using weird, not easily replaceable cables when playing live.

As others have said on old threads, you can see via the light on the front that the axe is receiving the midi, but it just isn't reaching the software through midi adapter mode. Looks like the Mac OS vs USB adapter mode problem still persists.

Unless anyone knows any different?
 

simeon

Axe-Master
if you're trying to get midi into ableton, make sure the axe fx midi port is checked in ableton's midi preferences as a source

i just turned on midi monitor on my mac and waggled my expression pedal. the axe is connected to the mac via usb and the board is connected to the axe via a standard midi cable. midi monitor shows midi data being received.

also make sure you can see the axe fx in audio/midi setup (midi pane) on the mac and it's enabled
 

Theurge

Member
yeah, thanks Simeon, well versed with Ableton. I'm using MainStage more these days. Problem is, the midi being passed (and I've being using Midi Monitor too) is 'invalid'. There's missing digits, characters, or whatever you'd call them. I've seen the same problem reported on other threads to do with USB adapter and mac os.
 

bondsong

Experienced
I had the same problem trying to send expression pedal data through to a VSTi on my Mac. The data sent for the expression pedal was CC 0 and value 0. It would be nice if this worked. Actually it would be great.
 
Top Bottom