• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

unable to Upgrade: need for a little help from my friends...

Kingfloyd

Inspired
I successfully upgraded firmware until Version 7. I however never succeeded going to 8. For months I always got the "transfer error" message at the end of the process with the Axe going back to 7. As I suspected that the problem was linked to Axe Edit, I decided to wait for the new editor to be made available. But this was months ago and as Axe Edit seems to be still some weeks away, I tried to update with Midi Ox. I really want to access the new scenes feature. I used the tutorial as posted by Stratamania (early this month). It was as clear as possible ... but...

For months I have been reading all posts related to Midi Ox and Firmware upgrading and I took notes ...I use a PC loaded with Windows 7. I uninstalled/reinstalled the Fas USB driver, uninstall/reinstalled twice Midi Ox, set Midi Ox on 128 bit/16 and set milliseconds between buffers to 60, uninstalled completely Axe Edit, downloaded a fresh copy of 9.02, reboot the axe and switched it off/on after each trial, switched of the pc and restarted it before each trial, stopped any other activity on the PC during the transfer, MFC disconnected from AXE... without any success. The axe screen shows the "file transfer" with a progress bar that hardly moves (after the end of the transfer, at the end of the process, the bar is about one third of the horizontal line). The process itself (before aborting) takes about 25'.

After five trials today, I am still in 7 (which at least allows me to continue to use the axe) and I have exhausted my resources. I do not know what else to do/test. Months ago I contacted the FAS support and was told that this was an Axe Edit issue, but apparently my problem is different.

I am close to ignorant in terms of PC and Windows and most probably I am missing something possibly obvious. While I love 7, I now want to get access to the new features and also upgrade my MFC.

Any guess ? (I know that there are many posts adressing this type of issue but I searched the forum without any success in finding what is wrong on my setup).

Thanks already.
 

Kingfloyd

Inspired
Have you tried a different USB port and/ or cable between the Axe FX and PC?

Actually I tried both Usb ports on the pc (and even removed the mouse). The cable is a brand new one I bought to replace the one I used earlier. (I may try the older one just in case ...). The cable could explain such strange behaviour ?

To be complete, the progress bar on the pc screen (midi ox activity) moves "normally" until reaching the far right of the right. That is only the progress bar on the axe screen that hardly moves.

Thanks for your help. Much appreciated.
 

s0c9

Moderator
Moderator
Did you check the progress bar on the Axe and see if it's moving, or got to the "REBOOT" message ?
DId you check firmware version in the Utilities menu ?? Still says 7.* ?

FWIW - I have never had ANY success using Midi-OX with the Axe-II.... just too many parameters... Bome's SendSX works better for me (win7 x64) .

Anyway, you should be fine using AxeEdit to upgrade the firmware - as long as that's all you do with it.
If changing cables/USB ports makes no difference, you could try SendSX or Elektron's C6 midi filer.
I use C6 for MFC upgrades.
 

Kingfloyd

Inspired
Now I tried a new cable, set buffer to 90 milliseconds, changed usb port, and tried both speeds 128 and 256, reboot each time. The progress bar on the axe screen now moves more quickly and is at 85% of its course when the fatal "Transfer Error" message appears. Would it be possible that the problem lies with the axe itself ? (I did not try SendSX as apparently it deals with only small size sysex).
 

stratamania

Fractal Fanatic
Do you know if you have USB2 or 3 ?

You say you did not try SendSX, under which menu?
Also what step did you take?

Will be offline after this post.
 

s0c9

Moderator
Moderator
Where does the message appear ?? On the Axe or ?
If it's on the PC, then perhaps you have something on the PC side that is causing the MIDI "fail".
Do you have another computer to test with? That would help prove out if the Axe was the issue or the PC.

Have you tried dumping banks to Midi-OX on the PC to see if things are working in that direction?
See Section 13.1.1. on 901 version of User Guide for details.

Basically, set up MIDI-OX to record/receive, go into Utilities..Preset tab on Axe and select one of the "Dump Bank * to USB" options.
Assuming it completes OK, save it from Midi-OX, then open AxeEdit, go to AxeManage, select the bank you just saved and see if it contains 128 presets from the backed up bank. If so, then my guess is the PC has something causing the failure...

you could try Elektrons C6 Midi filer too.... if all else fails.
http://www.elektron.se/sites/default/files/products/files/C6_1.4E_Windows.zip
 

Hucky

Member
I had the same problem, this is what fixed it for me: hold the "recall"-button, while powering up the Axe. This will load an empty preset, then update the firmware (I used Axe Edit). Hope that helps!

Cheers, Hans
 

Kingfloyd

Inspired
THANK YOU all ! I successfully upgraded to 9 this afternoon.
Finally the winning combination has been : "Hold the Recall Button" + "Elektron C6"
Would have never made it without your help.
Thanks for this Christmas present !
 

funny_polymath

Fractal Fanatic
BTW: Axe-Edit is FINE for upgrading FW and saving/recalling/shuffling banks (i.e. Axe Manage portion). I upgraded last night with AE. Not one problem. Smooth as silk.
 
Top Bottom