• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Bug? Per-Preset Compatibility

brianv4

Fractal Fanatic
Not really sure where to go with this. If it's an issue with Edit or a compatibility problem between the III and the 9 but when I transfer a preset from the AxeFx III to the FM9 (and vice-versa) the per-preset switches don't maintain their correct assignments.
 

brianv4

Fractal Fanatic
I'm setup so when I select a preset it links right to the scenes layout. Sometimes I use scenes (especially when checking out factory presets) but most of the time I'll use all per-preset switches overriding in the scenes layout.

I never use a block that isn't in both the III and the 9 so compatibility isn't an issue. But whenever I export a preset from either machine to the other, these assignment don't follow correctly.

Take the preset I'm attaching as an example, It's from the III. Checkout the switch assignments then load it in the 9 and you'll see what happens. And I realize there are 12 per-preset switches but 1-9 should line up. Sometimes it has the wrong block or channel or smart bypass isn't selected correctly. Thx!

Oh, and switch the cab block back to channel A. I'm using custom IR's on Channel C.
 

Attachments

  • JCM 800.syx
    48.2 KB · Views: 1
Last edited:

unix-guy

Legend!
I haven't loaded your preset but wanted to mention that switches are presented differently on an FC-12 versus an FM9.

FC-12 switches are like this:


Code:
7  8  9  10 11 12
1  2  3  4  5  6

FM9 are like this:

Code:
10 11 12 7  8  9
1  2  3  4  5  6

Are you checking switches by number or position on the layout?
 

brianv4

Fractal Fanatic
I haven't loaded your preset but wanted to mention that switches are presented differently on an FC-12 versus an FM9.

FC-12 switches are like this:


Code:
7  8  9  10 11 12
1  2  3  4  5  6

FM9 are like this:

Code:
10 11 12 7  8  9
1  2  3  4  5  6

Are you checking switches by number or position on the layout?
Yes I do realize, thx!
 

brianv4

Fractal Fanatic
Here's a visual example of whats happening. I took the preset in the OP and loaded it in the FM9. This is what happens:

EX 1:
EX 1 - III.png
EX 1 when loaded in the FM9:
EX 1 - 9.png

EX 2:
EX 2 - III.png
EX 2 when loaded in the FM9:
EX 2 - 9.png

Lastly EX 3:
EX 3 - III.png

And when loaded in the FM9:
EX 3 - 9.png
 

mr_fender

Axe-Master
I've wondered about this myself but haven't had a chance to test it. Are FC Per Preset functions stored as part of the FC data or in the actual preset?
 

brianv4

Fractal Fanatic
I would think per-preset has to be stored with the preset.
Agree.

This issue with per-preset assignments has been happening thru several FW versions, and not just with the blocks I've shown in the examples. Just glad I finally have some downtime to report it. I'll be away thru Tuesday but will do my best to follow the thread.
 
Last edited:

Rex

Legend!
I've wondered about this myself but haven't had a chance to test it. Are FC Per Preset functions stored as part of the FC data or in the actual preset?
All per-preset data — FC or otherwise — is stored in the preset. Otherwise, it would be lost when you load a saved preset.
 
Top Bottom