• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Need Help Making Backups - Max OS 10.6.8

Fro

Experienced
I'm not sure when things stopped working, but I've been running without a safety net for a while now. I want to make some major changes to my patches, so I want to back everything up. I'm running Mac Os 10.6.8 and use SysEx Librarian. I'm not able to upgrade to Lion or Mountain Lion yet for work reasons. Hopefully I can sooner than later. Until then, I need to make these patch changes to day and would like to back things up.

When I hook up with the USB, I can send user cabs to the Axe Fx with no problem. When I try to send things from the Axe Fx to the computer, then I have issues. With the USB connection, I hit record on SysEx librarian, but it never sees the info coming from the Axe Fx. I know there is some kind of bug or known issues with the USB driver and 10.6, but I was hoping to get at least this much working, even if it meant jumping through hoops.

I tried using my Uno and go with the old fashioned Midi set-up. This is the same Uno I use with my Standard with no issues. When I send a file with this hooked up, SysEx Librarian sees the info coming, but stops recording after about a second and only gets about 12k of info and then stops. I also tried my Midiman and my M-Audio 4x4 with the same result.

I do have a PC with Windows 7. I tried to install the Axe Fx driver and got an error. I tried the Uno with Midi Ox, but it wasn't immediately intuitive to me, so I decided to post here first. I would prefer to get the Mac set-up working, as it was working in the past, and I'm not sure what happened.

To recap. Mac OS 10.6.8. SysEx Librarian. I tried USB and regular Midi. I can send to the Axe Fx, but I can't receive info from it. Am I missing a setting on the Axe itself? Thoughts?

Thanks.
 

KittyForHire

Inspired
Are you using 'Record one' or 'Record many' on SysEx lib? You need to use 'Record many', or it will stop recording after the first SysEx message.
 

Fro

Experienced
Using "Record One", which is what I've always used. My understanding is that is used for one complete message, i.e. either one patch, one one complete bank. I should use "Record Many" if I'm going to send all of the patches individually, but all in a row. Then you don't have to keep hitting record. Based on the info it gets at the beginning and end, it will automatically separate them out into separate files. I could be wrong, but that's how I do it with the Standard.

An odd update. I also don't use Axe Edit, for obvious reasons. But I also stopped using Axe manage because it won't stay connected via USB. I'm connected right now via the Uno, and I'm backing everything up. It's a workaround, but I don't feel horribly safe opening Axe Edit. It also doesn't explain why the USB up and stopped working.
 

KittyForHire

Inspired
Mmm, that's not how it worked for me, Record One will just record a single SysEx message, and since a patch consist of several messages (30something), it won't even record a single patch like this. So yes, I think you need to use Record Many :)
 

Fro

Experienced
I'll go on record as disagreeing with you, as this is how I did it with my Standard last night, and all last year, but... I will say that sending and recording only one patch with "Record One" for me also does not work. It does the same thing no matter what I send it. It stops after 12k.

"Record Many" will also work for the way you are doing it, it's just unnecessary, as you won't be sending another bank when your done. Look at the file when your done, One file, therefore one message. I will also admit that I could be very wrong, as it's not working right now. lol

Axe Edit is almost done. Give me about 10 minutes and I'll try the "Record Many". Thanks for the suggestion too.
 

chris

Legend!
stop arguing :)

you have to use Record Many. but it doesn't mean "Record many different presets." yes, "Record One" used to work, but now it doesn't. move on.

when you press Record many, it will record many messages sent to the computer, not just one small 12kb or whatever file.

Press Record Many
Send the Preset to USB
SysEx Librarian will continue to record all messages from that ONE preset until the Axe is done sending
When the numbers have stopped increasing in SysEx Librarian, then press stop.

Now you have your full preset, bank, whatever saved to your computer.
 

Fro

Experienced
I am back, and thanks all for the help. "Record Many" it is, and worked like a champ, like you all said it would. Didn't mean to come across too negative. I just spent all last night doing it one way with the Standard, and I couldn't get it out of my head. Different hardware means different workarounds.

Can you confirm for me too then that the USB side of things just won't work then with 10.6.8? That just plain doesn't work no matter what button I press, this only works with the Uno. Again, I can send with USB, but I can't receive. If it's because of the operating system, then I'll just use the Uno and call it a day. I can get the USB to work in Pro Tools using the aggregate workaround, but it does crash Axe Manage, which it didn't used to do.

Again, thanks for the help.
 

Tone Seeker

Power User
I wanted to back up some patches last night. I'm running 10.6.8. Record One created a file that was too small. Record Many worked nicely. I confirmed it by sending the same file back in to another location.

I too thought I had used Record One on my Ultra.

Terry.
 

Fro

Experienced
FYI, I did also hook up my Standard just to confirm I wasn't bat-poop crazy, and "Record One" does work on the Standard for both banks and patches. But, what works for one doesn't work for the other. I just wasn't sure if it was pointing to another possible problem. Thanks Tone Seeker for checking too. What you have is showing me that my USB problem is another issue. You still have to use "Record Many", but it does work with the USB. I wonder why my USB only works in some directions, and not in all apps.

I should mention too that when I try the USB with Axe Manage, it does connect at first, but it loses the connection right away. You know, I have another Mac that's also 10.6.8, let me try that. At least I can figure out if it's a computer issue vs an Axe Fx issue.
 
Top Bottom