• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Mouse / Keyboard / RME Interface messed up by Axe [NOT A BUG]

Kooks

New Member
Hey there!

I just got a brand new Axe-FX II XL+ and began following the driver installation procedure. At one point the installer asked me to plug in my Axe via USB and turn it on (this was my first time plugging in the axe and turning it on, for the record). As soon as I did so my mouse and keyboard both became unusable. The Axe drivers were successfully installed, but my mouse / keyboard remained unusable. I tried switching the Axe and mouse / keyboard to various different USB ports but nothing changed. Turned the axe off / on / etc. anything I could think of.

I turned the axe off, manually restarted my computer and my mouse / keyboard were finally functional. I opened up TotalMix FX and my settings were completely erased and all the routings were switched back to factory default. I tried turning the axe back on with the USB connected but the same thing keeps happening: mouse / keyboard freeze, have to turn off axe, manually restart, TotalMix is reset to default.

Anyway around this?

Thanks.
 

Kooks

New Member
RESOLVED

Since reinstalling individual drivers for each piece of hardware didn't work, even in combination with changing USB ports, I resorted to reinstalling the drivers to all of the ports themselves. I did this by uninstalling each port one at a time found under 'Universal Serial Bus controllers' in Device Manager, then restarting the computer so that the USB drivers automatically reinstalled themselves.

After that I plugged in my keyboard / mouse, installed the drivers for that, then I did the same for the Axe FX. This time my controllers didn't end up freezing, not even after successful driver installation of the axe. Seems like everything is working fine now, and TotalMix isn't changing even after turning the axe on / off and restarting the computer.

Hope this helps anyone out there that might right into a similar problem.
 
Top Bottom