• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Bug? MIDI Through broken in USB MIDI

Per Boysen

Inspired
I just noticed that the MIDI Through is broken when it concerns USB MIDI.

This is what I did:
- Feeding a MIDI signal into the Axe's (physical) MIDI In port.
- Connecting a laptop by USB, running MIDI interactive software (both sending and receiving MIDI).

This is what happened:
- MIDI received at the AxeFx MIDI In port is not mirrored through the USB MIDI.

I experimented with Axe's i/o MIDI settings and it did not matter what status for "USB Adapter Mode" or "MIDI Through".

This bug doesn't hit my badly though, since I am able to get my rig working by adding a MIDI Jack to USB cable to bring over the MIDI stream from the Axe to the listening laptop. It would be nice to have the USB working properly though (one cable less to schlepp around)

Got 11.03 here and running Mac OS 10.8.4 on the laptop.

EDIT:
Just want to mention that other USB MIDI functions work ok (AxeFx follows MIDI Clock tempo given by computer through USB, for example). But MIDI received through the physical input is not passed as MIDI Through through the USB MIDI, only through the physical MIDI Out jack)
 
Last edited:

FractalAudio

Administrator
Fractal Audio Systems
Moderator
Working fine here on 11.03. USB Adapter Mode must be set to On.

To test this use two computers. Connect one computer to the Axe-Fx via USB. Connect the other via MIDI In/Out using a MIDI interface. Any MIDI information sent on either computer will be received by the other. I've done this test dozens of times. I use MIDI-OX to send/receive data.
 

Per Boysen

Inspired
Thank you for the feedback! Good news that it should work. I will look into it more soon to see what might cause my issue. One thing I did not investigate was the order I turned on the devices. I will also check with the Audio and MIDI Utility of OS X that the virtual MIDI channels are in place.
 

Per Boysen

Inspired
I had a second go on this issue today and found something new. When using Plogue Bidule's excellent MIDI Monitor 2.0 on the USB connected laptop I can see that the AxeFxII does indeed send through the MIDI Note events but both the Note On and the Note Off are sent with the velocity value 0 rather than the velocity 100 that is sent through a MIDI cable into the Axe's MIDI In port.

If sending a MIDI CC# sweep it is translated by the Axe as a series of CC# value 0 events. All the different values during the sweep are stripped off from what the Axe shares over the MIDI Through USB.

My rig still works though, I just turn off the AXE-FX II MIDI Out as an Input Device on the USB connected laptop software and plug in a MIDI-TO-USB cable instead (XP MIDI mate).
 

FractalAudio

Administrator
Fractal Audio Systems
Moderator
The Axe-Fx simply passes the data. It doesn't parse messages. If a message is arriving altered then the fault is in the monitoring software or the OS.
 

Per Boysen

Inspired
Yes, I was guessing it is the Mac OS failing to handle a USB connection properly - maybe due to the fact that the USB connection does both sending and receiving of MIDI messages?
 

vibechild

Member
I have also had trouble receiving MIDI over USB on a Mac. My problem was with getting MIDI data from the MFC to the computer, but it sounds related. There is a thread in the bugs section about it. The result of the discussion was that it was an OSX problem.
 

Mcboy

Member
I am having the same issue ...connect my midi keyboard midi out cable to my axe-fx II midi in port....I have midi thru on....usb adapter mode on...the axe registers midi comming in on the front panel blinking light when i press any key or chord on my keyboard. So there is midi communication. But the incoming midi "Notes" from the keyboard are only being sent out by the axe-fx midi out port and "Not by the USB cable".
This applies to midi note on and off . So my recording software"Cubase, Ableton, Logic X" do not see any incomming midi notes from the AXE even though the AXe is seen and recognized as a midi port. I cannot play my midi keyboard into the axe and have the axe send midi notes by USB into the daw. What will work is using a separate midi interface connected by a midi cable from the AXE midi out port to the midi in port of the interface and then to the computer. This makes eliminating the external interface and extra cable a non feature. I still love my AXE!
 
Last edited:

Mcboy

Member
I forgot to mention that I use a Mac iMac with OSX 10.84 and latest AXE drivers. I also tested the midi throughput of the AXE by usb cable with Midi Monitor 3.0 utility and midi NOTE on and midi NOTE off give an invalid value when playing my keyboard into the midi in port of AXE. So yes usb midi is not sending midi "NOTE" values that any of my Mac recording programs can recognize.
 

Mcboy

Member
I also have an eleven rack that has midi ports as well as usb midi. It has no issues sending midi from the midi in port through the connected usb cable. I am inclined to believe its a driver issue and not an OS X issue.
 
Top Bottom