1. We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.
    Dismiss Notice

MFC-Edit Window Scaling on HiRes Windows 10

Discussion in 'MFC-Edit' started by bwanagary, Jan 18, 2018.

  1. #1 bwanagary, Jan 18, 2018
    Last edited: Mar 22, 2018
    bwanagary

    bwanagary
    Expand Collapse
    Administrator
    Moderator

    Joined:
    Jan 15, 2013
    Messages:
    1,156
    Likes Received:
    831
    Location:
    Nashville, TN, United States
    There have been a few posts over the last year or so from users who purchased a hi-res but small (11, 12 or 13-inch) size laptop running Windows. The MFC-Edit window came up tiny on these displays making it too small to use in some cases. Thanks to the good work of MFC-Edit user Ronald Hoot who figured out a working solution and passed it back to me there is now a working solution that I've tested myself. Even better, it is simple to do once you know the steps. There may be minor variations depending on which versions of Windows and Java you have installed, but here are Ronald's notes, followed by my own and a screenshot.
    Thanks again Ronald for figuring this out and sharing it!

    1. Find java.exe you installed (Check C:\Program Files\Java\{version}\bin\java.exe and also, for the 32-bit Java version C:\Program Files (x86)\Java\{version}\bin\java.exe )
    2. Right click -> Properties
    3. Go to Compatibility tab
    4. Check Override high DPI scaling behavior (and experiment with display resolution settings here)
    On my own Windows 10 installation with Java 1.8_0_161 I had a slightly different set of options to Ronald with the option to "Disable display scaling on high DPI settings". Try turning this feature on and off and relaunching MFC-Edit. That worked for me.

    Here's the screenshot:
    Windows10-resolution-fix-2.png

    P.S.
    Please make sure that you make the setting changes for all Java executables. That would mean at least the following if they are present on your computer.

    Anything below C:\Program Files\... called java.exe, javaw.exe or javaws.exe
    Anything below C:\Program Files (x86)\... called java.exe, javaw.exe or javaws.exe
     
    iaresee likes this.
  2. #2 Kenny Burch, Oct 10, 2018
    Last edited: Oct 10, 2018
    Kenny Burch

    Kenny Burch
    Expand Collapse
    New here

    Joined:
    Jun 19, 2014
    Messages:
    12
    Likes Received:
    12
    Location:
    Canton, Ohio
    I purchased and downloaded the latest version of MFC-Edit. The first issue right off the bat was that the program GUI and the text are all miniaturized on my screen.
    I cannot read it. My computer screen is a 40" ultra HD monitor operating in UHD super high resolution mode. My other Fractal Audio software looks and operates fine except for MFC-Edit.
    Does anyone know of a fix for this to make the display screen of this program larger? Neither Fractal Support nor the Author have offered any support solutions...
    The Administrator solution above does not work for me.
    *Also I am on Windows 8.1
     

Share This Page