• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

bwanagary

Administrator
Moderator
Thank you all who continue to support MFC-Edit and provide valuable feedback on opportunities for improvement. This minor release has some usage enhancements geared to the first time or new MFC-101 users. Based on what we see the newer users having difficulty with in the forum and in the support ticket queue we've added some assistive features. There are a few more mouse-hover/tooltip messages that are helpful so you don't have to flip "pages" to look at settings and a new "Beginner" mode.

When MFC-Edit is a new installation, Beginner mode is "On" by default. At the moment the only place you'll see the effects of Beginner mode is when using MFC-Edit to transfer sysex dumps to and from your MFC-101. This is a finnicky process and nearly every new user has difficulty when they first attempt it with either Fractal Bot or MFC-Edit. Beginner mode can be turned off/on from the File->Preferences->GENERAL page.

We've also added a Trouble? button to the SysEx Receiver/Transmitter page - if your dump/load is failing, press this button.

So, in summary, this release is to simply make life easier for the newer users of the equipment. There have already been "Wizards" built into MFC-Edit for setting up Expression Pedals and Bank Style since earlier releases. Both the Beginner mode and Wizards will expand their scope as we discover where people need the most help.
-Enjoy!
 

acidfrost

Inspired
I'm on 5.2, I get a popup to upgrade to 5.5. Click yes and it I get the download screen but it stays at 0% forever. Tried to relaunch it, click no and update through the help menu instead, same issue. I tried turning my firewall off and still not working.
 

bwanagary

Administrator
Moderator
There's a DNS (networking) issue going on with the internet today, so some things aren't working. There isn't a bug in the editor so its probably the DNS issue. If not, it'll be a firewall issue. I would wait a bit and try in a few hours.
 
Top Bottom