• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

mfc-edit (OS X) Update Error (SOLVED!)

shinster

New Member
I've been running mfc-edit v.5.2.

Choosing "Check For Update..." gives me this prompt:
"An update is available... download it now?"


fractal_mfc101edit_update.png


Clicking on "Yes" apparently downloads the update, as it shows a progress bar:


fractal_mfc101edit_update_progress.png

...this, however, shows this warning --- "Failed update! Cannot run program /Applications/Fractal": error=2. No such file or directory"

fractal_mfc101edit_error.png

I tried re-downloading the app from my Fractal account / order form, but I get the same results.

Help...?

p.s. Java information:
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)
 
Last edited:

bwanagary

Administrator
Moderator
Thanks for the detailed debug and screenshots.
This is a known bug with version 5.2 - that's over a year out of date. You are doing the right thing downloading the latest. Here's the solution:
  • Drag MFC-Edit from your Applications folder into the Trash
  • In your home folder there's another folder called "MFC-101"
  • In that folder there will be a zip file called "mfc-edit-mac.zip"
  • Unzip that and double-click the mfc-edit.dmg file that appears
  • Follow the prompts
If that doesn't work then please open a support ticket and we'll take a look at it for you.
-G
 

shinster

New Member
Thank you. I think I figured this out.
Reasons why I haven't been able to update mfc-edit from 5.2 to 7.x are:
* My order page (from January 2017) / software download page has that version 5.2 only and sometime during this 5.2 installation, I changed the mfc-edit environment PATH (MFC-Edit UserHome) from ~/MFC101 to /User/Shared/Library/Fractal/MFC101 (and deleted ~/MFC101) thinking that prefs and dumps get saved there and that I don't ever manually have to open that dir. I personally don't want to clutter my home directory with application-specific directories. I also save a folders named "IR" and "SYX" inside /User/Shared/Library/Fractal.
* As you noted, 5.2 has an update bug so whenever I tried to update, it never actually did (even though it had downloaded the latest version into that MFC101 folder... and like I said, I never manually accessed that MFC101 folder!)

In hopes that I can replicate what I see, and for others who might've had the same issues, what I ended up doing:

* First, I installed from the dmg found inside MFC101 folder... Sure enough, like you said, there's a fresh installer. This installs version 7, and also creates ".mfcrc" in my home directory. I see that ~/.mfcrc saves the log path / PATH overrides
* But I wanted to make sure that I can replicate a correct, CLEAN installation, so I trashed the following: the mfc-edit app, ~/MFC101 and any other MFC101 folders I might've created for the mfc-edit installation (ex. /User/Shared/Library/Fractal/MFC101 in my case, which I created) ... and ~/.mfcrc that 7 creates...
(n.b., Actually, I saved some of my mfc dump / backup files in a temporary folder so I can reuse them later with a new mfc-edit installtion )
* Downloaded and installed 5.2 from my order page, dated January 19, 2017 The installer puts mfc-edit 5.2 in /Applications folder

*mfcedit_version5.png
* Launching this (...and without MFC101 folder) will bring up this dialog. Clicking on Yes creates the MFC101 folder. Say No to update.
mfcedit_thankyou.png

* Quit the app, copied back my previously saved mfc dump/backup files into that MFC101 folder, relaunched the app... OK, so MFC-Edit 5.2 is running again.
* At this stage, proceeded with Update. What it does is, it downloads a new installer inside MFC101 folder. But the app quits! (i.e. the update bug in 5.2). So, locate that installer (which is obviously different from the version I got from my order/download page). And install it!

mfcedit_newinstall.png

* Upon completion, the mfc-edit app in /Applications will be updated to 7.2...
* In an effort to always keep my directories organized, I moved the app to /Applications/Fractal Audio... which is where Axe-Edit, Cab-Lab, Fractal Bot, etc also live...

* I can confirm that by repeating above steps. 7.2 is working and I can load my old sys files from previous installations! Whew! :-D mfcedit_version5.png mfcedit_thankyou.png mfcedit_newinstall.png mfcedit_newinstall7.png


mfcedit_newinstall7.png



Thanks again, and keep up the great work!
 

bwanagary

Administrator
Moderator
Wow! Thanks for taking the time to post such a detailed solution for our other users. Another tidbit that might help is reinitializing MFC-Edit so that it looks like a totally fresh install, even if it isn't. For most MAC users the command would look like this:

/Applications/MFC-Edit.app/Contents/MacOS/mfc-edit.sh -clear initialize

Running this command from a Terminal session, after first making sure that MFC-Edit isn't running, will reset MFC-Edit to its initial state. Of course, if you have installed MFC-Edit into another location, say /Applications/Fractal Audio/MFC-Edit.app, then you would use that in the command line instead.
 

shinster

New Member
Thanks for the info.
I tried it just to see what it does, and it gave me all sorts of errors so I tried to find a workaround and I think I did, so I thought I'd report it. :)

OK, so I did this in the shell: /Applications/Fractal\ Audio/MFC-Edit.app/Contents/MacOS/mfc-edit.sh -clear initialize

The terminal output:
-clear initialize
Java execution EXIT STATUS = 1
The 'clear initialize' also wipes out PATHNAMEs and registration.
(i.e., Fractal Bot and Axe-Edit paths have to be set in the app, and registration code re-entered).

Also: It seems that MFC-Edit 7.2 wants to be in /Applications (i.e., not /Applications/SomeOtherFolder) and it doesn't want ~/.mfcrc (it needs to be deleted first) before doing /Applications/MFC-Edit.app/Contents/MacOS/mfc-edit.sh -clear initialize
so that it works properly. Upon which, it creates "MFC-101" folder in the home directory.

Any other way (such as having the app inside /Applications/Fractal\ Audio) and/or having ~/.mfcrc already will give a variety of errors such as 1) creating "MFC-101" folder with "docs" and "dump" subfolders with no content (i.e. no example.sys or manuals etc), or 2) resulting in "mfc-edit.sh: line XXX: .....no such file or directory" errors.

At any rate, a clean install of MFC-Edit accomplished! :)
 
Top Bottom