• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Niels Beier

Member
Hey guys,

I'm running my FX8 in front of my Marshall JVM model.
With my old setup, I ran a G-Lab GSC-3 looper in front of it, to do all my pedal-switching and channel changes via MIDI. Now that I've upgraded to the FX8, it's time for it to pick up where the G-Lab left off.

The thing is, I can't seem to get these two to work together. In a previous thread I mentioned a few issues I had with the FX8, and asked about MIDI.
My G-Lab looper could only send PC changes, and the Marshall picked those up perfectly, and made the correct channel switching. However, whatever I set the different MIDI-settings to, I just wind up with nothing..

In the I/O > MIDI settings in the Globals menu, I've got the following set up:
MIDI CHANNEL: 1
MIDI THRU: ON
PROG CHANGE: ON

For the individual scenes in my preset, I've got the following:
PC NUM: 8 (For that given channel on my Marshall. With the GSC-3, 8 meant OD-1, Orange)
PC CH: 1
CC NUM: OFF
CC CH: 1
CC VAL: 0

I've tried to change all values, including the CC's (though I don't see that being important, since my old looper didn't send CC, only PC)

What am I doing wrong here?

Note: I tried different MIDI cables, but it isn't a cable problem.
 

algiman

Member
Assuming you are using FX8-EDIT, re you setting this up on the "footswitches" tab or the "config" tab? I'm wondering if you are entering values against a midi block in the "footswitches" tab, but not actually using a midi block. For what you want to do, midi blocks are not needed.
 

Niels Beier

Member
I'm just programming on the pedal itself, since I don't have a computer near my rig.

I'm working on the CFG tab, not in a MIDI block.
 

algiman

Member
That should work then, Obvious things to check - is the amp set to channel one too? Are you using the right midi sockets on the FX8 and the amp (I myself have spent ages trying to figure out what was wrong when I had plugged the midi cable into the thru on my amp, rather than the in!)
 

bread

Experienced
In the midi section of the FX8 try sending a CC number of 18 with a value of 1.

According to the manual this should select the OD1 Orange channel.

Make sure the JVM and try FX8 are on the same midi channel.
 

Niels Beier

Member
In the midi section of the FX8 try sending a CC number of 18 with a value of 1.

According to the manual this should select the OD1 Orange channel.

Make sure the JVM and try FX8 are on the same midi channel.

Tried this too! However, I found the problem!
 

Niels Beier

Member
Hey guys! Figured out what the issue was!

The guy I bought my multi-cable from had only soldered 3 wires onto the MIDI cables, since that is what's commonly used. I bought a new MIDI cable today, and it works like a charm. Sorry that I didn't take the time to check this, the cable worked perfectly till this point, so I didn't figure the problem was there.
 
Top Bottom