• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Logic Pro X Users: How Can I Enable Advanced Tools and Disable Input Monitoring?

The Raven

Member
Hello everyone,

I know this is probably a problem with a simple solution, but I've done my best to Google/figure it out myself and have not been able to so please hear me out. I just got Logic Pro the other day and am attempting to record some tracks with my Axe Fx 3. Before I get to the issue, let me just say that the Axe is connected to my Mac via USB, and my studio monitors are connected to the Axe Fx via output 1. The Axe fx is the only audio interface I have connected at this time as well, so I'm using it both for recording and playback.

Now to the problem at hand. Strangely, if I enable the Advanced Tools in Logic's preferences section, I hear both the direct audio from the Axe FX as well as the delayed playback from the stereo out in Logic. So essentially, whenever I try to record I'm hearing 2 sounds simultaneously, resulting in a chorusing effect as the stereo out in Logic introduces latency. If Logic's Advanced Tools are disabled/hidden, the stereo out has no playback when recording aside from the metronome or other unarmed tracks. I've attempted toggling the input monitoring on/off as well, but that doesn't fix the issue.

The only non-solution-solution I've found is I can mute the stereo out in Logic when recording, but this is not ideal as it will also mute my metronome as well as all other recorded tracks, thereby making recording a full song incredibly impractical. Is there some way to prevent this situation from happening? I've attached screenshots just in case that may be helpful just in case my description doesn't sound like it makes sense. I can try to record a video as well but I don't know if it would post properly to the forum.

Any insight would be appreciated. This is one of the first times I've ever tried recording myself in earnest, so again I'm really sorry if this is literally the most simple/easy solution and I am just too inexperienced to see it.
 

Attachments

The Raven

Member
preferences > audio > general

software monitoring = off
I knew it was something simple I was missing. I feel foolish because I honestly didn't even realize the Audio Preferences got several subsections added once I enabled the Advanced Tools.

Thank you so much. Also, your ambient presets are absolutely amazing.
 
Top Bottom