• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Logic Pro X Controlling III (unwanted)

plasmatic

Member
I'm wondering if anyone else has this issue, when I have Logic open and my III connected via USB, when I change tracks in Logic it is changing scenes in my Axe. It will also bypass blocks. It doesn't matter if my Axe is the audio interface or my Focusrite USB interface. As long as I have the Axe connect via USB Logic is sending commands and the Axe responds. Any ideas on how to make them stop talking?
 

TrickRichards

Inspired
I’m having this issue as well. The only fix I know is to go up to Logic Pro X - Control Surfaces - Bypass All Control Surfaces. You’ll have to do this every time you open Logic. Anyone else have a better fix?
 

is9582

Power User
Is this with the new Logic Pro 10.5? I’ve never experienced this with my setup.

If not using 10.5, which version are you using, and do you have any control surfaces setup in Logic?
 

plasmatic

Member
Is this with the new Logic Pro 10.5? I’ve never experienced this with my setup.

If not using 10.5, which version are you using, and do you have any control surfaces setup in Logic?
I'm using version 10.4.8 and "Bypass All Control Surfaces" didn't clear it.
 

plasmatic

Member
So it looks like if I change the midi channel on the III to "2" it stops. Where do you set the midi channel in Logic? Apparently it is set to channel 1 and I can't find where to change it.
 

plasmatic

Member
Do you have a MIDI track selected in a Logic probject?
Not on all of the projects. I can start a new project and add audio tracks only and they will change Scenes when I select between them. I don't have to record anything. At this point, changing the III to midi channel 2 has mitigated my problem. I'm sure it is a Control Surface setting that I need to change but I can't seem to find anything related to Output channel (or something like that).
 

GlennO

Fractal Fanatic
Not on all of the projects. I can start a new project and add audio tracks only and they will change Scenes when I select between them. I don't have to record anything. At this point, changing the III to midi channel 2 has mitigated my problem. I'm sure it is a Control Surface setting that I need to change but I can't seem to find anything related to Output channel (or something like that).

The problem is not the channel, it’s almost certainly the midi port you have defined for the control surface. I’m guessing that if you go to control surface setup you’ll find a control surface that is defined as using the AxeFX midi port.
 

plasmatic

Member
The problem is not the channel, it’s almost certainly the midi port you have defined for the control surface. I’m guessing that if you go to control surface setup you’ll find a control surface that is defined as using the AxeFX midi port.
So to test this I went ahead and put my III back to midi channel 1 and tried "Logic Pro X - Control Surfaces - Bypass All Control Surfaces" again, and this time it worked because I didn't actually get a check mark by it the first time I tried it. I did this time and it stopped changing my III. So, that says it is definitely the Control Surface sending the messages. I rebooted Logic and you have to select Bypass All Control Surfaces again like TrickRichards said. I left them on (not bypassed) after rebooting, changed tracks and watched my III change as well. Went in and changed my III to midi channel 2 again and it stopped being controlled by Logic. I've been digging around CS in Logic and don't see anything defined for my III (just my Akai midi keyboard that is not hooked up). I don't see an output port setting to change in the CS settings but that doesn't mean much. And, just to be clear, I didn't play with CS settings before this started I've just been using Logic like I always do. It might be a Catalina OS thing for all I know.
 
Last edited:

LigLury

Member
I'm on Logic 10.2, so this might have changed. Go to Preferences and on the Control Surface tab you should see a checkbox for "control surface follows track selection" which you would want to uncheck.
Screen-Shot-2020-05-17-at-11.50.51-PM.jpg
 

plasmatic

Member
I'm on Logic 10.2, so this might have changed. Go to Preferences and on the Control Surface tab you should see a checkbox for "control surface follows track selection" which you would want to uncheck.
View attachment 67600
I tried this and no go. I also don't have anything checked in "try unchecking everything in the sync prefs in logic...globally and in the project settings" that I can tell like Simeon suggested. I'll try to put some screen shots together to show my settings in Logic. Right now the only thing that works (besides bypassing CS commands every time I open Logic) is changing the III midi channel.
 

GlennO

Fractal Fanatic
I'm sure something was changed without your intervention for some strange reason, but my best guess is still the same: you have a control surface defined and the output port for the control surface is mistakenly set to the AxeFX III. Look for a control surface in the Control Surfaces Setup window. Either that or something is mixed up in the Audio/MIDI Setup app and your control surface midi port is mistakenly attached to your AxeFX.
 
Last edited:

plasmatic

Member
Thanks for the suggestions so far, I made a video to show how it behaves. Hopefully you can read the on screen text but you get the gist. If you see something I overlooked let me know. I'm just using Midi Ch 2 in my III for now.

 

GlennO

Fractal Fanatic
You're not overlooking anything, but as I mentioned above, the problem is Logic is treating your AxeFX as a control surface. Try deleting your com.apple.logic.pro.cs preferences file.

This has nothing to do with midi preferences in Logic.
 

simeon

Axe-Master
logic > preferences > midi > inputs > uncheck axe fx

logic > preferences > midi > reset messages > uncheck all


edit: i think glenn is right. did you try
logic > control surfaces > controller assignments - delete anything axe related
logic > control surfaces > setup - delete anything axe related
logic > control surfaces > bypass all control surfaces
 
Last edited:
Top Bottom