• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

How to activate tuner from MIDI Controller FCB1010?

johnrousteau

New Member
Hi Friends,

I use midi controller Beringher FCB1010. I want to know if it's possible to activate tuner of the axe fx II from FCB1010? I know it's not possible to have tuner on the screen of the FCB1010. But I just want to activate From FCB1010 a preset with no sound and have tuner on the screen of my axe fx II.

Could you help me?

Thanks in advance,

John
 

pyba

Member
Bump!
I had the same difficulty because you actually to send a CC with a value >64. A CC with a value smaller than that will toggle the tuner off.

But I still have a question, is it possible to toggle the tuner on/off with the same pedal? I haven't found a way yet.... Not sure it is even possible...
 

pyba

Member
Ok it is apparently possible with the Uno chip it is called CC Toggling: if you define the 2 possible CCs with the same CC number and two different values, the FCB will alternatively send the two values each time you push the switch.

But for whatever reason it is not working for me, but since I have other weird reactions from the FCB, I just ordered a new 1.04 Uno chip... I'll let you know if this solves my issues...
 

paranoid

Fractal Fanatic
The fcb will send on off values with the same switch using the standard e-prom. You will have to program the switch so one press sends a value above 64 and a second press sends a value lower then 64.
 

pyba

Member
Yes that's what I did, but it doesn't work... What I did is that I selected both CC for the switch in the editor one with value 65 and one with zero....

I have found a workaround by sending a single CC to activate tuner (which works) and selecting a patch to exit tuner...
 

Ugly Bunny

Power User
Here's how you do it:

1. Assign a CC to the tuner (in Axe)
2. Whatever switch you want to use as your tuner, go into edit mode for that (FCB)
3. Turn on pedal 6 and set it to CC[XX] (whatever CC you assigned to the tuner in the Axe)
4. Set the value to 127.
5. Turn on pedal 7 and set it to CC[XX] (whatever CC you assigned to the tuner in the Axe)
6. Set the value to 0
(6a) I can't remember if you only need one CC for the tuner like you do for other effects if you have the toggle mode turned on. If so, ignore steps 5 & 6. If I think of it, I'll double check this evening.

Done, son! I've got a few videos on YouTube about setting up various things and my own personal setup. Search "Axe-Fx III & FCB1010 Ugly Bunny" and they should pop up. I've posted the links here, too, so should be easy enough to find. Good luck!
 

Arturo Civit

New Member
Here's how you do it:

1. Assign a CC to the tuner (in Axe)
2. Whatever ...

Thanks so much, ok I did that, but then, when I save everything and check, when I hit the switch I selected to work as tuner activates the patch number, so maybe I'm loosing something. Any idea? Thanks a lot man!
 

stringrazor

Inspired
Thanks so much, ok I did that, but then, when I save everything and check, when I hit the switch I selected to work as tuner activates the patch number, so maybe I'm loosing something. Any idea? Thanks a lot man!

Each button can be set to do many things simultaneously:
- up to 5 MIDI Program changes
- up to 2 MIDI CC msgs
- 1 MIDI Note on/off msg
- Open/close Switch 1
- Open/close Switch 2
- Define value for Exp pedal A and /or B or disable them

If all you want to do is send CC values, you need to make sure that the pedal button you are setting is ONLY doing that otherwise results will be unpredictable. I highly recommend using an editor like Ripwerkx as it really helps to visually show you what each button is programmed to do.
 

Ugly Bunny

Power User
Thanks so much, ok I did that, but then, when I save everything and check, when I hit the switch I selected to work as tuner activates the patch number, so maybe I'm loosing something. Any idea? Thanks a lot man!
Well, make sure you don't have any PC switch on (make sure when you're in edit mode for the switch you want to use as your tuner, you don't have pedals 1-5 lit up. 8&9 are okay since those are the exp pedals.
 

Arturo Civit

New Member
Well, make sure you don't have any PC switch on (make sure when you're in edit mode for the switch you want to use as your tuner, you don't have pedals 1-5 lit up. 8&9 are okay since those are the exp pedals.

Well, in the one I want to work as tuner when I hit the edit mode, I have pedals 1, 6, 8 and 9 lit up :(
 

Arturo Civit

New Member
Just push and hold pedal 1 to turn it off - too easy :)

That was the reason it changed presets; PCs (buttons 1-5) change presets.

Thanks a lot decreebass, but no, not working, every time I step on a pedal to activate the tuner it jumps to that preset on the axe fx...
 

Ugly Bunny

Power User
Thanks a lot decreebass, but no, not working, every time I step on a pedal to activate the tuner it jumps to that preset on the axe fx...
I don't know what to tell you, then. The only way it would go to a preset is if a PC were being sent. The only way a PC would be sent is if the FCB1010 was sending one with the press of that pedal. If you've gone into edit that pedal and the ONLY pedals lit up are 6, 8, & 9, then there's no reason it should be sending a PC.

The only other thing I can think of is that maybe you have some sort of direct select configured that's tied to the same CC you use for the tuner (?).

Sorry I couldn't help - good luck!
 

danielworks

Member
For some reason I can't make secondary CC work in my unit. @Ugly Bunny some months ago gave me some tips after commenting in one of his videos. For a workaround I just had to use another switch to turn off the tuner with CC#00.
Also I tried the instructions documented in the video but also didn't work for me

"Only One CC Needed To Toggle Effects! In the MIDI/Remote "General" setting tab, if you set "Eff. Bypass Mode" to "TOGGLE," then you need only one CC to toggle effects on or off, not two. You don't need to have one set to 127 and one set to 0 unless you have it set to "VALUE." Just set pedal 6 to the appropriate CC and the value to 127 and you're good to go"
 
Last edited:
Top Bottom