• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Help me make Axe-Fx II sound be heard through the PC

hummale

New Member
So as the title says, im having some troubles. The axe-fx itself works fine, i can plug headphones in and it all sounds great. I have connected the axe II to my pc via usb cable and opened axe-edit but i cannot seem to hear any sounds? The axe-fx is being recognized by my pc, but i cannot hear any guitar. Is it possible make it so that the axe-edit sound (e.g. my guitar) can be heard through my pc audio so i can play to backing tracks and such with headphones on? How would i do that if its possible? Please make it noob friendly as i just purchased my axe II.

Thanks a bunch!
 

lauke-lux

Power User
Yes of course you can. Install the driver corresponding to your windows version, hence either configure your PC sound card as the principal host in your daw or switch your daw to the axe fx asio driver and hear all over your axe fx headphones output. Pls note that you will lose some pct of cpu load that might disturb some cpu-heavier patches
 

hummale

New Member
Yes of course you can. Install the driver corresponding to your windows version, hence either configure your PC sound card as the principal host in your daw or switch your daw to the axe fx asio driver and hear all over your axe fx headphones output. Pls note that you will lose some pct of cpu load that might disturb some cpu-heavier patches
Thanks for the quick reply! My DAW is basically just axe-edits and in that client i only seem to be able to change Ports 1 and 2 which are both MIDI ports, not any kind of input or output settings as far as I can see. Any idea what to do? Would be so much easier if there was options for output and input, cuz then i could just set input as my Axe-FX II and output as my headphones that are currently inserted into my PC
 

unix-guy

Legend!
Thanks for the quick reply! My DAW is basically just axe-edits and in that client i only seem to be able to change Ports 1 and 2 which are both MIDI ports, not any kind of input or output settings as far as I can see. Any idea what to do? Would be so much easier if there was options for output and input, cuz then i could just set input as my Axe-FX II and output as my headphones that are currently inserted into my PC
Axe-Edit is not a DAW - it is an editor for the Axe Fx settings. There's NO audio transmitted via Axe-Edit.

You need to install the USB driver if you have not already done so.

You will then need your Axe Fx plugged in and turned on.

Then go to your Windows Sounds settings in Control Panel and select the Axe Fx as your sound card. Note that this will change the output for everything on the computer. Some programs allow you to select the output specifically for that program, so you could also do that.

On the Axe Fx in the global settings you will need to turn up USB Return Level.

Edit: just re-read the OP and see that you are wanting to hear the Axe Fx thru the PC rather than the other way around. That would require some form of software (like a DAW) to accept the incoming audio over USB and route to the computer's audio.
 
Last edited:

chris

Legend!
almost all audio interfaces are designed to have your speakers/headphone plugged into it directly. with the Axe connected via USB, it's acting as an audio interface, so it's designed to have speakers or headphone connected to it.

further, almost all audio interfaces can send the PC sound through itself. so your computer sound would come through the Axe to Out 1 or Headphones. again, this is sort of the basic way audio interfaces function.
 

lauke-lux

Power User
Axe-Edit is not a DAW - it is an editor for the Axe Fx settings. There's NO audio transmitted via Axe-Edit.

You need to install the USB driver if you have not already done so.

You will then need your Axe Fx plugged in and turned on.

Then go to your Windows Sounds settings in Control Panel and select the Axe Fx as your sound card. Note that this will change the output for everything on the computer. Some programs allow you to select the output specifically for that program, so you could also do that.

On the Axe Fx in the global settings you will need to turn up USB Return Level.

Edit: just re-read the OP and see that you are wanting to hear the Axe Fx thru the PC rather than the other way around. That would require some form of software (like a DAW) to accept the incoming audio over USB and route to the computer's audio.
All is in the answer of unix legend. To be bit a more versatile I'd strongly recommend to use DAW like Cubase LE. For starting to work with digital audio and recording it's a good solution. It will take you a few hours to get started but after it's really more comfortable.
 
Top Bottom