• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Fractal-Bot 3.00.06 file selection (linux & wine)

Ingo

Inspired
Disclaimer: I know that Linux is not supported. I still hope to get valuable input on this issue, and I very much hope that it can be resolved.

While trying to update FM3 firmware in linux & wine (something that was trivial so far with the AxeFx III), I discovered that from 3.00.05 -> 06 something changed drastically:

In 3.00.05 I can select the device (AxeFx III), it auto-detects the USB connection, I can select a firmware file, and then send it.
In 3.00.06 (rest unchanged), selecting the file does NOT show the filename in the box, hence I cannot send it.
Edit: Just checked with the internal FractalBot 3.00.07 of FM3-Edit, same as 3.00.06 (cannot select a file, same error).

When the file selection fails, console output reproducibly shows the message
wine 0009:fixme:pidl:SHGetNameFromIDList Unsupported SIGDN 80068000
Quick googling indicates that this seems to be some kind of issue resolving path names or similar..

Any ideas?
 
Last edited:

volt

Inspired
Discovered the same issue :( Due to lack of time I just went back to 3.00.05... but would be good to find a "real" solution.
 

Ingo

Inspired
The same error is responsible for something I could not make sense of before: For at least a few weeks now, I have no longer been able to select the workspace dirs (presets, blocks etc) in Axe-Edit 3, the field just gets emptied. In this case there's an easy workaround available by just editing the settings file manually.
 

crataegus

New Member
I can reproduce this issue and swapped back and for forth between the version 3.0.6 and 3.0.4 to find the difference. It must have something to do with the select-file dialog. In the new version it looks different and I guess the simulated explorer gets opened in a different way (see screenshots) so it cannot communicate back to the fractal-bot to enter the file.

Long time ago I had a similar issue with opening files within a wine-program. The solution was to force wine opening all explorer dialogs with added parameters. Will post it here if I can find it again.

BTW - Nice to see other Linux users here!

Screenshot_Fractal-Bot_3.0.4.png Screenshot_Fractal-Bot_3.0.6.png
 

Attachments

  • Screenshot_Fractal-Bot_3.0.4.png
    Screenshot_Fractal-Bot_3.0.4.png
    324 KB · Views: 8
  • Screenshot_Fractal-Bot_3.0.6.png
    Screenshot_Fractal-Bot_3.0.6.png
    299 KB · Views: 9

volt

Inspired
Good news!

Just tried Fractal-Bot 3.00.08 on Wine 6.5 and the selected firmware file is shown again in the white box next to the browse button :D

OS: openSUSE Tumbleweed
 
Top Bottom