• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

FM3 Firmware Release Version 1.06

Randalljax

Fractal Fanatic
I know it would be a difficult thing to ask but as an experiment what if all FM3 users we stick to just using are own presets or factory ones for a period of a week. and see , if we eliminate all the 3rd party presets and conversions , if people were willing to do that
would the freezing stop or be noticeably less ?
 

Edrod

Experienced
someone posted something above that I’d forgotten about. The day before my freeze, I foolishly tried to install a complicated AxeFX III preset but it was too CPU intensive. Then I couldn’t delete it. Once I thought it was gone, I turned off the FM3 for the day. The next day that preset was still there and I finally got rid of it by copying an <EMPTY> preset. The unit froze up a little after that but hasn’t since.
It's interesting that you mention this. I've had about 2 freezes since I received my fm3. I've had it for about 2 month now. If I recall correctly, I remember my fm3 freezing around the same time I was going full stupid trying out a bunch of different presets from fm3 to X3.
 

Phil M

Inspired
It's interesting that you mention this. I've had about 2 freezes since I received my fm3. I've had it for about 2 month now. If I recall correctly, I remember my fm3 freezing around the same time I was going full stupid trying out a bunch of different presets from fm3 to X3.

Yup, I just roll my own now.
 

ruso

Power User
1. I looked at my other preset yesterday. It is constantly oscillating between 83-85%. I've been playing it for 2 months and it never hangs like the preset I put yesterday (the one with model Friedman). This preset uses the Boutiqe 2 amp and is sound-stable at all times. So, maybe the problem lies in the Friedman HBE amplifier model code fragment?

2. It is almost impossible to track CPU usage on the FM3 screen in the Layout screen (for me). The numbers are tiny, you must kneel over the device to see what is going on there (or be young and have healthy eyes ? :D). Perhaps there are red stripes displayed there, indicating that the border has been crossed - but I am not able to see them. Maybe it would be a better idea to have the ENTIRE bar (the one for CPU USage) displayed in orange / red when the preset starts to overflow some bounds (not just its right edge, while everything else is still blue). It would be much better, especially when FM3 is on the floor and the eyes are almost 2 meters higher ;)
So you can look at FM3-Edit - but as I wrote before, problems with USB make me almost quit the editor, because I really prefer to play than restart FM3 or the computer every now and then.

3. Regarding the CPU Usage and the power reserve to operate the screen / buttons, LED - one of the advantages of the new DSP (used in FM3) was to be that it contained a separate core (ARM style core? I remember correctly?), which was dedicated to this jobe, while both cores the DSP was to be occupied only with signal processing. Then why can we not use DSP power to the level of e.g. 95% (I know that it is always worth having a headroom - but does it really have to be up to 20% of the processor power?). Scaling the CPU Usage is probably not the way to go - rather optimizing your algorithms so you can use more CPU power, have I right?

4. I am still a huge fan of Fractal and please don't take my comments as an attack. I just wish I could trust the device while using it. And still waiting for firmware fixes.

Best regards for Team from Fractal

The issue I have is that the FM3’s CPU was maxed out before it was even in buyers’ hands. Many of the presets that I made running 1.03 no longer work with the latest release. That is very disheartening when one would think that the software would be more optimized in later releases, not the opposite. Yes, the processors were chosen to meet a specific price point, but I would have been more than willing to spend an extra few hundred dollars on a unit that had room for growth. Add the fact that it’s still missing many of the features that were promised and bugs that prevent me from trusting the unit 100% for a gig, I am somewhat unhappy with my purchase.
 
Last edited:

vetteboy79

Inspired
I know it would be a difficult thing to ask but as an experiment what if all FM3 users we stick to just using are own presets or factory ones for a period of a week. and see , if we eliminate all the 3rd party presets and conversions , if people were willing to do that
would the freezing stop or be noticeably less ?

That's all I've done, the only time I've hooked up the USB was to update to 1.06. Otherwise I record via SPDIF. I've done a ton of session work with it and just find something close, tweak a little on the unit to fit the context of the mix, and get tracking. Haven't messed with scenes or changing any of the buttons at all, it just lives on my studio desk. Been flawless for me since early April.
 

bishop5150

Fractal Fanatic
The issue I have is that the FM3’s CPU was maxed out before it was even in buyers’ hands. Many of the presets that I made running 1.03 no longer work with the latest release. That is very disheartening when one would think that the software would be more optimized in later releases, not the opposite. Yes, the processors were chosen to meet a specific price point, but I would have been more than willing to spend an extra few hundred dollars on a unit that had room for growth. Add the fact that it’s still missing many of the features that were promised and bugs that prevent me from trusting the unit 100% for a gig, I am somewhat unhappy with my purchase.
That’s unfortunate. I’ve been gigging my FM3 since May without a single issue.
 

moerker

Experienced
Just for the report:
Got an unresponsive unit first time at the rehearsal yesterday. It happened as I was fast switching between presets with the FC, presets where around 60/70% CPU.
Actually, putting the stuff together sounds like race condition problems to me. But apart from that no problem here.
 

giannishreds

Inspired
Whenever I experience freezes, it's with a Friedman preset or a preset that was converted from Axe III which was downloaded from the Preset Exchange. Also, on a couple of occasions, I noticed the delay was still trailing when changing scenes within the same preset.
 

PBGas

Inspired
I don't think I am going to import anything when mine comes in. I'll just create new based on what I have on the 3 and go from there. It's not that big a deal to do and kind of fun actually. No gigs up in these parts these days so lots of time to get this done and enjoy.
 

Boomsma

New Member
I have mini displays missing sometimes ...apparently this is a known bug..
Also on factory presets or user-presets that had something in the displays before?
Some user presets have per-preset switch overrides that might not be set on your device, then they show up as an empty label.
 

Randall d

Experienced
Just had my first lock-up. I was using a switch hold to change presets and the main screen and the scribble strips went blank (though still illuminated). No sound. Had to reboot to get it working again. FW 1.05.
 

LosD

Member
Just had my first lock-up. I was using a switch hold to change presets and the main screen and the scribble strips went blank (though still illuminated). No sound. Had to reboot to get it working again. FW 1.05.

Hi, was this a factory preset or a custom one by any chance?
 
Top Bottom