• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

FM3-Edit 1.04.01

Michael Pickens

FAS Software Engineer
Fractal Audio Systems
Moderator
FM3-Edit 1.04.01 is now available via auto-update or from our website:

https://www.fractalaudio.com/fm3-edit/


RELEASE NOTES

VERSION 1.04.01
May 25, 2021

Current FM3 Firmware Version: 3.02

SYSTEM REQUIREMENTS
  • Mac version requires OS version 10.7 or newer
  • Windows version requires Windows 7 or newer
  • Minimum firmware version 1.00

NEW IN THIS VERSION

PLEASE NOTE:

Starting with firmware 2.00, FM3-Edit 1.02.00 (or greater) is required to communicate with the FM3.
Previous versions of FM3-Edit (versions 1.01.10 or less) will not work with firmware 2.00 or greater.
FM3-Edit 1.02.00 (or greater) will continue to work with all previous firmware versions.

* Modifications to allow the windows (main editor, Preset Level, and Axe-Change) to be moved to external monitors.

* Corrected Preset Leveling window dimensions.

* Corrected "IR Length" visibility in CAB block for fw 4.00 public beta 1.

* Corrected AMP block Dynamics page and Authentic layouts for fw 4.00 public beta 1.

* Added "Show Folder" menu item to the Perform View's Per-Preset Performance Controls menu.

* Added "Copy to End" to the Copy submenu of the Scenes dropdown menu. This will copy the current scene to all of the scenes that follow. For example, selecting "Copy to End" from Scene 3 will copy Scene 3 to Scenes 4, 5, 6, 7, and 8.

* Modified Manage Cabs and Manage Presets to retain the currently assigned color when renaming items.
 
Last edited:

Admin M@

Administrator
Fractal Audio Systems
Moderator
Check out those groovy release notes, boys and girls:

* Modifications to allow the windows (main editor, Preset Level, and Axe-Change) to be moved to external monitors.

* Corrected Preset Leveling window dimensions.

* Corrected "IR Length" visibility in CAB block for fw 4.00 public beta 1.

* Corrected AMP block Dynamics page and Authentic layouts for fw 4.00 public beta 1.

* Added "Show Folder" menu item to the Perform View's Per-Preset Performance Controls menu.

* Added "Copy to End" to the Copy submenu of the Scenes dropdown menu. This will copy the current scene to all of the scenes that follow. For example, selecting "Copy to End" from Scene 3 will copy Scene 3 to Scenes 4, 5, 6, 7, and 8.

* Modified Manage Cabs and Manage Presets to retain the currently assigned color when renaming items.
 

Jambi

Inspired
Allowing the windows to windows to be moved to external monitors is awesome! Will this work with the preset selection screen as well?
 

ZSauce89

Inspired
Check out those groovy release notes, boys and girls:

* Modifications to allow the windows (main editor, Preset Level, and Axe-Change) to be moved to external monitors.

* Corrected Preset Leveling window dimensions.

* Corrected "IR Length" visibility in CAB block for fw 4.00 public beta 1.

* Corrected AMP block Dynamics page and Authentic layouts for fw 4.00 public beta 1.

* Added "Show Folder" menu item to the Perform View's Per-Preset Performance Controls menu.

* Added "Copy to End" to the Copy submenu of the Scenes dropdown menu. This will copy the current scene to all of the scenes that follow. For example, selecting "Copy to End" from Scene 3 will copy Scene 3 to Scenes 4, 5, 6, 7, and 8.

* Modified Manage Cabs and Manage Presets to retain the currently assigned color when renaming items.
Yeeeeeeee
 
Just maybe a minor cosmetic "bug". On amps without "overdrive" knob, the lower controls in the ideal amp page are spaced evenly across the grid, while on amps with "overdrive" control, the knobs and switches become more dense. Posting examples here >

Powerball (controls are spaced evenly)

Screen Shot 2021-05-25 at 21.29.41.png

Savage (controls are more dense)

Screen Shot 2021-05-25 at 21.29.52.png
 

Petrocelli

Inspired
No big deal, but the preset leveling window is now against the release notes slightly cutted under 1 04 01 and relativly big!

Leveling window.JPG
 

Petrocelli

Inspired
That's not happening here for me on Mac 10 11.2.3 or Windows 10. Do you possibly have any unusual display settings?
I run win 10 with standard Intel UHD 630 Graphic. Two Monitors with Full HD Resolution and default settings! The yesterday version 1 04 00 hasnt this problem!
 

Michael Pickens

FAS Software Engineer
Fractal Audio Systems
Moderator
No big deal, but the preset leveling window is now against the release notes slightly cutted under 1 04 01 and relativly big!

View attachment 83781
You can also try closing the editor, deleting your "FM3-Edit.settings" file, and restarting.

The settings file is found in:
Windows: C:\Users\<user name>\AppData\Roaming\Fractal Audio\FM3-Edit
OSX: <user name>/Library/Application Support/Fractal Audio/FM3-Edit
 

Petrocelli

Inspired
You can also try closing the editor, deleting your "FM3-Edit.settings" file, and restarting.

The settings file is found in:
Windows: C:\Users\<user name>\AppData\Roaming\Fractal Audio\FM3-Edit
OSX: <user name>/Library/Application Support/Fractal Audio/FM3-Edit
Hey Michael, thank you for the Tip! Cleared the "FM3-Edit.settings" file und it shows normal!
My Machine runs Win 10 20H2.

Another Question: The non working "Master Bias Excursion" Parameter is gone? or haven't i find it on a new location?
 

mwc2112

Inspired
If you assign a control-switch modifier to a parm and then turn it on for the current scene in the Controllers->CS per Scene it doesn't change the target to the 'on' value until you leave that scene and come back (or if you turn it off in the CS per Scene it exhibits the same behavior, will stay on the 'on' value until you switch scenes and come back).

I did notice this in the previous FM3-Edit as well, so it may not be a new bug.
 

Greg Ferguson

Fractal Fanatic
Fixed: Never mind. I'd reset the global settings and missed turning on the IDEAL setting for the Global > Tone Control Display setting.

I'm seeing my tone controls reset from their original values to 5.0 when doing a soft-reset. I'm on 4.0b2 using FM3-Edit 1.4.01.

My amp block is displaying the Authentic screen. Switching to a different amp type immediately resets B/M/T to 5.0 and stays that way when I reselect the original amp type.

I reset the system parameters, wiped all the presets, reloaded the firmware, layout, factory and my presets and my (few) IRs, told Edit to refresh after the Firmware (multiple times), refreshed the presets and cabs from their managers. Edit's options are all on except "Prompt on edited preset when changing or importing..." and "Default the Amp block to "Ideal" because I like the authentic view. I even deleted Edit's prefs and cache and let it rebuild them.

I remember in the past that Edit would remember the values when I switched between amp types, but it's not doing that now, which might be part of the problem.

I'm baffled.

This is prior to the reset...
Screen Shot 2021-05-28 at 4.14.48 PM.png
I selected a different amp-type...
Screen Shot 2021-05-28 at 4.15.16 PM.png
And the tone controls are all reset to 5.0 but the Drive is still correct, and returning to the original amp stays at the 5.0 values...
Screen Shot 2021-05-28 at 4.15.37 PM.png
 

Attachments

  • FM3-210528-162643-system+gb+fc.syx
    192.6 KB · Views: 2
  • TK Imperial MkII.syx
    24.1 KB · Views: 1
Last edited:

unix-guy

Legend!
I'm seeing my tone controls reset from their original values to 5.0 when doing a soft-reset. I'm on 4.0b2 using FM3-Edit 1.4.01.

My amp block is displaying the Authentic screen. Switching to a different amp type immediately resets B/M/T to 5.0 and stays that way when I reselect the original amp type.

I reset the system parameters, wiped all the presets, reloaded the firmware, layout, factory and my presets and my (few) IRs, told Edit to refresh after the Firmware (multiple times), refreshed the presets and cabs from their managers. Edit's options are all on except "Prompt on edited preset when changing or importing..." and "Default the Amp block to "Ideal" because I like the authentic view. I even deleted Edit's prefs and cache and let it rebuild them.

I remember in the past that Edit would remember the values when I switched between amp types, but it's not doing that now, which might be part of the problem.

I'm baffled.

This is prior to the reset...
View attachment 83941
I selected a different amp-type...
View attachment 83942
And the tone controls are all reset to 5.0 but the Drive is still correct, and returning to the original amp stays at the 5.0 values...
View attachment 83943
I think you must use Ideal for that to work.

See the recent thread posted by yek:

https://forum.fractalaudio.com/thre...ed-to-know-about-reset-an-amp-iii-fm3.173317/
 
Top Bottom