• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Can a Preset Change Turn a pedal off?

shawngs

Member
Hey guys, is there a way, when I change a preset, to have the new preset turn on some effects and off others? I assume there is but can't quite figure it out. I don't own an axe FX and am using the MFC to control MIDI gear. I know that on the "Presets & Ex. Devs" page in MFC-Edit you can have the IA switches initial state be off or on but its not actually turning off any effects when I change presets. i.e. whatever effects were on in the previous preset remains on.

Please help. :)

Presets.jpg
 

shawngs

Member
I've got a TC Electronics Nova Drive. I can control it fine via the MFC but when I change presets it remains on. I'd like it to turn off (disable the OD or Dist) when I change to another preset.
 

chris

Legend!
I don't remember, but is there a "send IA on preset change" option or similar on the MFC?
 

bwanagary

Administrator
Moderator
There is, but the Send With Preset only works when the MFC is not in Axe-Fx mode I think. When the MFC-101 is in Axe-Fx mode then all the other IA Switch functions are not executed. You might be able to use the internal CCs (check the INT.CC and CHANGE MAPS page of MFC-Edit). Select an INT. CC, name it "TC Nova D", select the MIDI channel its on, set the CC# to send and the On and Off values. Then go to the PRESETS page and for the Preset that needs to send the "Off" CC# make sure that the "Internal CCs state" for that INTCC is "out/off" - with the "Red" LED showing. Then when that Preset is switched to it will send the CC# for the Off value of that INT CC off the INT.CCs & CHANGE MAPS page.

Conversly, if you want a preset to send an On CC then have the corresponding INT CC initial state button depressed - Green LED. That's not the only way I'm, sure, but that should work. You can "copy/paste" settings from one Preset into another one or more Presets also by using the Copy/Paste button on the PRESETS page of MFC-Edit.
 

shawngs

Member
Thank you for the info! I've set the Internal CC's accordingly (I have a lot more to control than just the Nova Drive)

Internal CC.jpg

and Set the IA switches to their appropriate settings for each preset

IA States.jpg

Now when I change presets all of the effects turn off regardless of how the Initial state is set. I did set them both the same (switches and internal) because I don't know which one/both I should select. Is there something that I'm missing to have some turn on now per preset?
 
Last edited:

bwanagary

Administrator
Moderator
Go into the setup of the actual MFC-101 and verify the ON/OFF values, the CC# and the MIDI channel of oone of your INT CC's and make sure that they are the same as the Editor shows. You should also be aware that the more INC CCs you send with preset changes the more latency/delay there will be when you switch presets.

I can see that, MIDI channel 3, for example, will be sent the following commands when you change presets:
  • CC #4
  • CC #120
  • CC #122
  • CC #5
  • CC #82
  • CC #3
The value that will be sent will depend on whether the INT.CC "button" is ON or OFF in the selected preset. When you say "All the effects turn off..." do you mean all the effects in your TC (assuming that is what on MIDI Channel 3) ?

Can you hookup the MIDI from the MFC-101 to a MIDI monitor - Snoize maybe - to see what it is actually sending? Maybe I need to add a MIDI monitor to the next major release of MFC-Edit ;-)
 

shawngs

Member
Thanks for the help. I realized (after much head scratching) That my Pod HD Pro will toggle a preset on or off regardless of the value sent to it (0-127). Unlike typical midi gear which has 0 = Off and 127 = On (or 0-63 = Off, 64-127 =On), it always toggles no matter what is sent to it. I can't send a distinct "Off" message because it will just toggle to the opposite state that its in. I've now got everything working by setting "Send w/prst" to "no" and "GBL" to "no" on the IA page, turning off all Internal CC messages, setting the IA Switches initial state to how I want them, and programming the pod to match the switches. My other gear (Rocktron Patchmate Loop 8, TC G-Major II, and TC Nova Drive) all work great based on the IA initial state since they receive 0=on/127=off messages.

Thank you Chris and bwanagary for your time and guidance!
 
Last edited:
Top Bottom