• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Bug? - Formant With Expression

Fro

Experienced
This definitely could be user error, which is why I said "possible" bug. This is a patch I use for Bon Jovi's "It's My Life". It's a patch I used for a few years with my Axe Fx II, and I rebuilt it for my Axe Fx III. I can't get seem to get this one to work right on the Axe Fx III. The issue is with the Formant block and tau-engage. It's set so that the Formant block is auto-engage with off being heel down.

Almost all of my auto-engage patches are set for off being toe down, and I usually use the "medium position" setting. This is one of the few patches where I need to to be heel down. I also use it for one other song, and I don't touch the expression pedal at all for that song. Since I come to the patch and leave the patch in those cases with the toe down, I use the "fast speed" setting instead. This setting does work on the Axe Fx II. On the Axe Fx II, if you come to the patch and never touch the pedal, the block never engages. If you touch the pedal, the block will engage, but then it won't turn off until it's heel down. On the Axe Fx III, when you select the patch while the expression is toe down, the block will be off, behaving like the Axe Fx II.

When you move the expression pedal, the block will turn on, but it will not turn off for me when I put the heel down, except.... if I go into the External Control settings and change the "Off Value" it will work. It doesn't matter what you change it to. If it's at 5%, change it to 6%. If it's at 6%, change it back to 5%. As long as you don't leave the patch, the auto-engage works. But as soon as I go to another patch and come back to this one, auto-engage will turn on but not turn off again. I thought maybe a higher off value was the issue, and even tried 10% instead of 5%. But just like before, it works once I make the change and I'm staying on the patch, but as soon as I go to a different patch and come back, the block won't turn off once it's on.

I'm using an MFC-101 Mk III. My expression pedals are Mission pedals. I have calibrated them. I have not tried this with other blocks. Again, this is the only patch I'm using where it's heel down for the auto-engage.

I'm hoping maybe I'm just missing a simple setting. I'm attaching the Axe Fx III patch. If it helps, I could also attach my Axe Fx II patch.

Thanks!
 

Attachments

  • RS-2 Its My Life.syx
    48.2 KB · Views: 2

Fro

Experienced
Just an update: I had a chance to do some more testing. I did try all of the speed options for auto-engage, slow, medium, and fast. None of them will turn the Formant off if I switch to another patch and come back. But they will work if I change the off value and stay on the patch.

I also tried this with the Wah block, and I got the same behavior. So it's not tied specifically to the Formant block, and it seems to be with all of the speed options with auto-engage. Either the behavior has change from how is was on the Axe Fx II, or I'm missing something, or it's a bug. Does anyone else use the speed options for auto-engage, and have you had any issues with it?
 

flying_walrus

Experienced
don't have a III yet, but I've noticed on my AX8 that the preset can be saved with the Wah or Formant on, instead of reading my mind that I want it off. have you made sure the block is bypassed when you save the preset?
 

Fro

Experienced
have you made sure the block is bypassed when you save the preset?

Good question, and yes. And when I go to the preset, the block is off like it should be. It's the behavior that follows that's funky. It turns on when I move the pedal, it just won't turn off once it's on. But it will turn off if I mess with the "off" value, even if i change it, and change it back to what it originally was.
 

Rex

Legend!
It turns on when I move the pedal, it just won't turn off once it's on. But it will turn off if I mess with the "off" value, even if i change it, and change it back to what it originally was.
Maybe it’s time to calibrate the pedal.
 

Fro

Experienced
Maybe it’s time to calibrate the pedal.

I considered that too, and I have. Calibrated it several times. Every time comes up with the same result, zero for the bottom number and 116 for the top. And the pedal will turn the block off properly if I change the "off" value in the preset (and it doesn't matter what value) as long as I don't leave the preset. It's when I leave and return to the press that it doesn't work properly.
 

Rick

Fractal Fanatic
@Fro I will try to look at mine tonight. I seem to remember a setting somewhere that is supposed to read the position of the pedal on preset loading, but can't recall where it was (or if it still exists in the III). That may be the position setting you're already using, but I'd like to double check it. I'll let you know.

I also got some pedal position weirdness upon using my new rig for its first live outing this past weekend. It just engaged on its own, with no pedal movement. Honestly, I am not certain it isn't the pedal itself. I am modding another reliable pedal for the reverse polarity of the MMGT and will do some testing on that too.
 

Fro

Experienced
@Fro I will try to look at mine tonight. I seem to remember a setting somewhere that is supposed to read the position of the pedal on preset loading, but can't recall where it was (or if it still exists in the III). That may be the position setting you're already using, but I'd like to double check it. I'll let you know.

Yeah, I was having other pedal issues with initial values. That was affected by turning the tuner on and off and mentioned by a few of us in another thread. Setting the initial value to 100% fixed that. This, however, isn't a problem with the initial value. The state of the pedal is correct when I select the preset. And the effect engages correctly when i move the pedal. The effect won't disengage when I put the pedal heel down if I use the speed options instead of position options. But the speed options do work as soon as a modify the off value. All of the position options for auto-engage work with the heel down setting regardless of off value, and even when I leave the patch and come back. I only get the problem with the speed options.
 

Rick

Fractal Fanatic
Gotcha. I misunderstood the problem (no shock there!). I'll continue following this to see how it resolves.
 

WITELITE

Experienced
This definitely could be user error, which is why I said "possible" bug. This is a patch I use for Bon Jovi's "It's My Life". It's a patch I used for a few years with my Axe Fx II, and I rebuilt it for my Axe Fx III. I can't get seem to get this one to work right on the Axe Fx III. The issue is with the Formant block and tau-engage. It's set so that the Formant block is auto-engage with off being heel down.

Almost all of my auto-engage patches are set for off being toe down, and I usually use the "medium position" setting. This is one of the few patches where I need to to be heel down. I also use it for one other song, and I don't touch the expression pedal at all for that song. Since I come to the patch and leave the patch in those cases with the toe down, I use the "fast speed" setting instead. This setting does work on the Axe Fx II. On the Axe Fx II, if you come to the patch and never touch the pedal, the block never engages. If you touch the pedal, the block will engage, but then it won't turn off until it's heel down. On the Axe Fx III, when you select the patch while the expression is toe down, the block will be off, behaving like the Axe Fx II.

When you move the expression pedal, the block will turn on, but it will not turn off for me when I put the heel down, except.... if I go into the External Control settings and change the "Off Value" it will work. It doesn't matter what you change it to. If it's at 5%, change it to 6%. If it's at 6%, change it back to 5%. As long as you don't leave the patch, the auto-engage works. But as soon as I go to another patch and come back to this one, auto-engage will turn on but not turn off again. I thought maybe a higher off value was the issue, and even tried 10% instead of 5%. But just like before, it works once I make the change and I'm staying on the patch, but as soon as I go to a different patch and come back, the block won't turn off once it's on.

I'm using an MFC-101 Mk III. My expression pedals are Mission pedals. I have calibrated them. I have not tried this with other blocks. Again, this is the only patch I'm using where it's heel down for the auto-engage.

I'm hoping maybe I'm just missing a simple setting. I'm attaching the Axe Fx III patch. If it helps, I could also attach my Axe Fx II patch.

Thanks!
I took your patch and it worked fine. Sounds like a calibration thing. Sounds cool :)
 

Fro

Experienced
OK, so I recalibrate my expression pedal again, and the block still won't turn off. It turns on, but not off. I tried 2 other expression pedals, recailbrating both times, same thing. I also tried a different MFC-101 with another set of expression pedals, making sure I calibrated them, and still no go. The block always turns on just fine, but will not shut off if I'm using any of the speed options for auto-engage. It will temporarily work if I change the off value and not leave the patch. What am I missing that nobody else has this problem? It has to be some obvious thing I'm forgetting to check. And FYI - I hook the same MFC-101 with the same controllers and same calibration up to my Axe Fx II, and the block will disengage just fine.
 
Last edited:

WITELITE

Experienced
I use a mission engineering one and it worked right away with your preset. (Heel down turns it off)

???

One thing to perhaps try is to plug the pedal directly into the axe III. Set it to internal 1 and see if it works. If it does, you know it will be something with your MFC set up.

And for what it's worth , here are how my pedals are configured in the MFC)

Screenshot 2018-05-07 22.15.35.png

MM
 
Last edited:

Fro

Experienced
I use a mission engineering one and it worked right away with your preset. (Heel down turns it off)

???

One thing to perhaps try is to plug the pedal directly into the axe III. Set it to internal 1 and see if it works. If it does, you know it will be something with your MFC set up.

MM

Thanks for trying it. I really do appreciate it. Yeah, who knows why it's giving me grief, but I'm glad it works for you. At least that means it's not a bug. Good suggestion on plugging directly in. I will give that a shot next and see if that works. Just curious, is your Mission pedal plugged into an MFC-101? And if so, do you know what Firmware it's on? Just wondering what differences there may be with your setup and mine. I think I have another Midi controller somewhere that isn't an MFC. I think a Midi Mongoose. Maybe I'll try that as well.
 

WITELITE

Experienced
Expression pedal is plugged into MFC. I think it's like 3.08 or 3.09. I did notice the beginning value is "off" in the screenshot. Perhaps that has something to do with it.

Good luck

MM
 

Fro

Experienced
I took your patch and it worked fine. Sounds like a calibration thing. Sounds cool :)

I might be on to something. I went back to the calibration thing. If I follow the MFC Manual steps to calibrating, it doesn't work. When I do this, my heel number gets set to zero. But if I manually move the pedal up and away from the heel position, I can get it to work if I set the lower value to 4 or higher. That means your right, calibrating was the issue. But it only works if I fudge the numbers. As long as that doesn't mess up anything else, I'm actually OK with that.

Thanks for the kind words on the patch. We do the Bon Jovi song as a three piece, no keyboards. So I play the key parts on guitar. I need the Formant to shut off quick when I jump between the guitar and keyboard parts. It freaked me out the past couple shows when the Formant was still on. So I was tap dancing between patches to get through the song. This fix might do it.
 

WITELITE

Experienced
Shouldn't mess up anything else. Only ones to watch I think would be pitch shifting, whammy's where 0 and 128 would be full octaves but you can adjust for that if needed.

Best

MM
 
  • Like
Reactions: Fro

Fro

Experienced
OK, I thought that adjusting the bottom number in my pedal calibration fixed the problem, but I came back today and it’s doing it again. I’m at a loss for what to try next...
 
Top Bottom