• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Best/Cheap Midi Foot Controller for the III

decreebass

Veteran
This thread has been really helpful- thank you to everyone who's contributed the step by step how to's on programming the FCB. I'm working with mine right now- I've followed @decreebass 's directions for setting up scene selections, and they make sense, but for some reason, the buttons I've programmed for scenes just aren't working- I've set up buttons 1-4 for scene selections, and 9 and 10 for preset up and down, and I think I get the logic of how each are set up, but for some reason, the buttons that aren't assigned (#5, 6, 7 and 8) are selecting presets, and the rest of the buttons that I've programmed aren't doing anything. I've got the scenes set to channel 34, and it's set that way in the Axe, and I know the midi is getting through because I can select presets- but anything that I've programmed just isn't responding. I kinda feel like this might be an issue with a global setting in either the FCB1010, or an incorrect setting the AF3, but has anyone here experienced something like this? Thanks in advance for any advice!
In whatever bank you're in, Pedal 1, which you've assigned to select scene 1, should have ONLY PEDAL 6, 8, & 9 lit when you're in edit mode. Pedals 6 & 7 are the CC pedals. With pedal 6 lit, tap it once until it's blinking. Then tap "UP" to confirm. It should read "34;" tap "UP" again. It should now read "0" or "00" as the value (for scene 1). This means that Pedal 1 in that bank is set up now to go to Scene 1. Repeat for Pedal 2 in that same bank. Except the value now will be "1" to go to scene 2. Etc.

I also recommend going into pedals 6, 7, 8, and 9 and disabling the PC (pedal 1 in edit mode). At the very least, you don't want to be sending any extra CCs or PCs.
 

Adman103

Veteran
You want to set the CC to 34, not the channel.
My mistake- I have 34 selected in the Setup>Midi/Remote>Other>Scene Select value, which is where it should be set, I think...

In whatever bank you're in, Pedal 1, which you've assigned to select scene 1, should have ONLY PEDAL 6, 8, & 9 lit when you're in edit mode. Pedals 6 & 7 are the CC pedals. With pedal 6 lit, tap it once until it's blinking. Then tap "UP" to confirm. It should read "34;" tap "UP" again. It should now read "0" or "00" as the value (for scene 1). This means that Pedal 1 in that bank is set up now to go to Scene 1. Repeat for Pedal 2 in that same bank. Except the value now will be "1" to go to scene 2. Etc.

I also recommend going into pedals 6, 7, 8, and 9 and disabling the PC (pedal 1 in edit mode). At the very least, you don't want to be sending any extra CCs or PCs.
Thanks for the reply! I've checked my settings, and that's how it's all set up, and I went into 6, 7, 8, and 9 and disabled the PC, and still nothing when I press those buttons. Are you working with the FCB in the Midi Function mode? i.e., not Direct Select mode, right?
I went through last night, reset everything on the FCB and programmed in the 1-4 buttons for scenes, and still no darn scene select. Also- do the Scene Increment and Scene Decrement on the III have to have values for this to work? I currently have them both set to "None". Thanks again all for the help- it's much appreciated!
 

decreebass

Veteran
My mistake- I have 34 selected in the Setup>Midi/Remote>Other>Scene Select value, which is where it should be set, I think...



Thanks for the reply! I've checked my settings, and that's how it's all set up, and I went into 6, 7, 8, and 9 and disabled the PC, and still nothing when I press those buttons. Are you working with the FCB in the Midi Function mode? i.e., not Direct Select mode, right?
I went through last night, reset everything on the FCB and programmed in the 1-4 buttons for scenes, and still no darn scene select. Also- do the Scene Increment and Scene Decrement on the III have to have values for this to work? I currently have them both set to "None". Thanks again all for the help- it's much appreciated!
Ah. You must not be using the stock chip. I'm out of my depths if you have an "upgrade"chip inserted.

But yeah, if you've turned off the PCs and the CCs in pedals 6-9, then it makes sense they wouldn't have any effect. I don't get what you mean you programmed the buttons 1-4 for scenes but you're not getting any scene select. What is happening? I wonder if maybe you have another MIDI function in the Axe programmed to CC 34? That's all it should take in the FCB: A CC pedal set to 34 with a value of 0 to 7 to select scene 1 through 8. This is a seriously rudimentary function and I'm not understanding why it's not working - unless you're in a weird mode of the FCB or you have something other than the stock chip. Maybe try to make a video of how it's set up and what it's doing...

Scene INC/DEC will need to be set up by you to whatever you choose. If you watch my videos, I have a spreadsheet where I keep track of all my CC assignments. You should do the same. So you could set Scene Select to 34, INC to 35, and DEC to 36; this is how I have mine set up.

EDIT: Also, if this isn't already obvious, make sure you only have a MIDI cable going from the FCB out to the Axe in - and NO cable going back to the FCB.
 

Adman103

Veteran
Seriously, thank you for the help! I really appreciate being able to get some advice from more experienced users here! Ok, I've been messing with this for awhile now. PC commands are working, CCs aren't. I'm not sure if it's my FCB, or if I have a setting somewhere that's goofy. I picked this up used, and it didn't say anything about having an Uno or Eureka installed, but I'm pretty darn sure that I've programming this right according to the stock chip instructions- I've added some views to all of your videos (which are really clear and helpful) and got things set up similarly, but when I set up anything with a CC, it just doesn't respond at all- there's no change in the AF3. I'm gonna look up some instructions on how to crack this thing open and see if it's been messed with. Again, thanks @unix-guy and @decreebass for the help!
 

decreebass

Veteran
I wonder if maybe the previous owner has the CCs being sent to a different MIDI channel... The FCB allows you to send each function to a different channel if you wish (so you can control multiple pieces of gear). I think you said you factory reset it, but I wonder if that resets the MIDI channels, since that's a global function...

It's kind of a pain in the ass to check, and you'll need the manual to check/set the channels of each function.

Have you tried using the CCs to do other functions (toggle effects on/off, preset INC/DEC, etc.)? Are you saying that no CCs are working at all?

Also, make sure you're working from a consistent bank on the FCB; like, if you're on bank 00 setting up scene changes and stuff, then you click UP or DOWN to another bank, the things you set up aren't going to work. I'm not trying to insult your intelligence, of course, just trying to think of everything. I have a feeling it's gonna be "doy" moment when you figure out what the issue is - I'm hopeful we'll get this sorted. Worst-case scenario, I can Facetime you or something and we can try to get it figured out.
 

unix-guy

Legend!
One more simple thing to check: when you press a button assigned to a CC, does the Midi light on the front of the Axe Fx flash?

If so, at least you know Midi is being transmitted.

You can also connect the FCB to your computer and use a midi monitor like Midi OX to see what is being sent.
 
Top Bottom