• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Basic setup for Logic Pro X

JDM_Dave

Member
Can anyone point me int the right direction on how to set up the AXE FX III to record with Logic Pro X. thanks
 

Corinthian

Inspired
Where exactly are you having difficulty?

If you've set up the Axe-FX as the input/output device in Audio MIDI Setup then it's just a case of creating a new audio track in Logic and selecting inputs 1 & 2. You'll need monitors or headphones connected to the Axe-FX as all the Logic audio will come through that way.
 

JDM_Dave

Member
when loading up logic.... it doesn't seem to find the axe fx signal. it just defaults the guitar to logic presets and they are horrible lol. is the a setting on the axe fx I'm missing?
 

Axeman

Inspired
As Corinthian explained above, are you sure you have the track inputs set correctly? The Axe is like any other device that you used as an input into Logic. Do other devices work in Logic?
 

Corinthian

Inspired
when loading up logic.... it doesn't seem to find the axe fx signal. it just defaults the guitar to logic presets and they are horrible lol. is the a setting on the axe fx I'm missing?

When you create a new track are you selecting Audio or Guitar/Bass?
 

nhgtrman

FAS Social Media Advocate
Do you have the Axe-Fx III selected under Preferences/Audio/Input Device?
 

Attachments

  • Screen Shot 2019-03-02 at 4.58.14 PM.png
    Screen Shot 2019-03-02 at 4.58.14 PM.png
    295.7 KB · Views: 144

JDM_Dave

Member
Hey guys, iv been trying everything that you have suggested and I'm still coming up with nothing. I have the fractal running into my Mac mini via usb and I'm using studio speakers running out of output 1 + 2 on the back of the axe FX. when loading logic its asks what type of track I want to load, songwriting, hiphop that sort of thing. im selecting either new or multi track, going to my preferences and selecting input as the axe fx. none of the tracks pick up the sound or if I jig things around I can get a signal but there's no sound on playback. im really stumped. im guessing this is a easy fix, is there something im missing?
 

Corinthian

Inspired
There does seem to be a bug somewhere affecting USB and audio. Are you running Mojave?

If so, if you have your Axe-FX plugged in and selected as the output in Audio/MIDI Setup, try playing iTunes. On my machine if I press play in iTunes it doesn't play - the 'play' button changes to 'pause' but the cursor doesn't move and there's no sound. In my case if I unplug the USB and plug it back in, without shutting either unit down, then it works fine.
 

JDM_Dave

Member
There does seem to be a bug somewhere affecting USB and audio. Are you running Mojave?

If so, if you have your Axe-FX plugged in and selected as the output in Audio/MIDI Setup, try playing iTunes. On my machine if I press play in iTunes it doesn't play - the 'play' button changes to 'pause' but the cursor doesn't move and there's no sound. In my case if I unplug the USB and plug it back in, without shutting either unit down, then it works fine.


yes this can happen to me using iTunes if I switch the axe fx off but leave my Mac on. this doesn't seem to be the case in logic though . I'm running latest updates on both devices and made sure logic was up to date.
 

JDM_Dave

Member
do I need to be using an interface? I'm currently not.. the axe fx is plugged straight into my Mac. please let me know
 

seclusion

Experienced
I wonder if it’s worth it to try and record in logic without the Axe.
Use the onboard mic, even just talking.
I didn’t catch if u had any other interface, if so try that.
This could be a Logic thing.
Sorry if u already posted that.
Other things to do are smc and the other reset on the Mac.
 

MSS

Experienced
I82E4C344-EF59-4326-8059-B516A6B821CE.jpeg You are creating a new audio track and not instrument track correct? In Logic I select input 1 and 2 and have my input recording device set to AXE III. The recording project settings are set to 48k 24bit.
 

rodzimguitar68

Fractal Fanatic
Can anyone point me int the right direction on how to set up the AXE FX III to record with Logic Pro X. thanks

1. Create an Aggregate Device. Go into Finder, Applications, Utilities, AudioMidi Setup. click the plus sign in the bottom left, and create a new aggregate device. On the right side of this window,check the ins and outs of your computer and your axe fx. Now, you have a new virtual sound card containing all of your ins and outs. Name this Aggregate Device something unique so you know it's the special one that you need to always use.

2. Open Logic - Preferences, Audio, choose the new aggregate device as your input and output source

3. Click on an input channel. Make the input mono or stereo, to suit your purposes. Choose the correct axe fx input. The Main outputs 1 L and Right are the first two USB inputs in the Axe Fx, but, if you checked the box for your Mac first, and then the Axe Fx second, when you set up your Aggregate device, the first two inputs will be your Mac's built in Mic in Stereo, and inputs 3 and 4 will actually be the main output 1, left and right, of your axe fx. If this messes with your mind, create a new aggregate, or edit your aggregate (close Logic before you edit your aggregate), and choose the Axe III's ins and outs first, and then secondly, choose the Mac's Ins and outs. Now the Axe III's stuff will be the first 8 ins of your Aggregate, and your built-in Mac Mic will be your inputs 9 and 10 of your aggregate.

4. Click on the output of the channel, and choose the main outputs of your computer itself

5. Arm the record button and play the song. Record your guitar for a measure.

6. Stop and listen to whether a track was recorded.

NOTE: Sometimes Logic will revert to something other than the Aggregate device, and you will freak out because your Axe Fx inputs will be "greyed out" and not selectable. This means you need to go into the Logic preferences / audio again, and once again choose the Aggregate Device as your Input and output source. This usually happens to me if I have Logic open, and then turn on my Axe FX and I have learned now, to double check that Logic is using my Aggregate Device, not the Mac sound card, or the Axe Fx itself.
 
Last edited:

BrazosGuitar

New Member
I have my monitors hooked up to the output from axe iii Via XLR cables. How do I get the Logic output to play through the monitors? It’s important that I can play sound from the Mac through the monitors as well as the axe!
 

mcmurray

Inspired
If anyone has the same problem, permit Logic to use your Microphone in System Preferences - Security and Privacy (f#*king stupid I know but that fixed it for me after hours of troubleshooting).
 
Top Bottom