• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Axe-Fx III USB I/O seems to disable Core Audio (Mac - more below)

SacredGroove

Inspired
Again - it may be an Apple issue, BUT since many of us are locked into that world, we really need the help of Fractal to help us analyze the issue. We need to be able to use our Fractal gear in a relatively seamless manner.
There are other threads on this forum about this topic, and the USB (dis)connection issue is not exclusive to Apple. This issue isn't new either! Here is a thread with Windows users: https://forum.fractalaudio.com/threads/usb-disconnecting.146587/

From everything I've read, the common denominator is the Axe III.
 

SeismicDispatch

New Member
Please explain - I don't understand how they would impact/affect I/O between the Axe and the Mac.

Not sure what programs you are running but you could review the apps that have "microphone" (or I/O) access in your security settings.

Go to: System Preferences > Security & Privacy > Microphone

Hope this helps.
 

Matt007

Inspired
Not to hijack the thread, but a related issue I have is crackling / popping audio when trying to play Spotify or YouTube videos. I don’t think it’s related to the AX8, but it’s a real pain in the @ss. I’ve updated all drivers and optimized power management to no avail. Had no issues for years and now it’s rendered my studio monitors almost irrelevant because the crackling is constant. There are no issues with the AX8 signal, just other audio from the computer and only happens when using the USB hub.
 

grape

Experienced
For those having this CoreAudio issue on the Mac rather than reboot use the Terminal to restart CoreAudio. The command is as follows.

sudo killall coreaudiod

It only takes a second or two to restart.

I’m aware of that but it does not fix the issue. So far, only a restart works. For those who liked the previous post, are you liking because it fixed the issue for you? If so, please post your configuration. There may be more issues than the one posted by the op but I have exactly the same issue as the op. Most of the thread is noise (no offense).
 

grape

Experienced
Not to hijack the thread, but a related issue I have is crackling / popping audio when trying to play Spotify or YouTube videos. I don’t think it’s related to the AX8, but it’s a real pain in the @ss. I’ve updated all drivers and optimized power management to no avail. Had no issues for years and now it’s rendered my studio monitors almost irrelevant because the crackling is constant. There are no issues with the AX8 signal, just other audio from the computer and only happens when using the USB hub.

Start another thread... it’s not related.
 
Hi all,

Brand new Fractal Audio customer here and had my FX III delivered on friday. I'm also experiencing the same issue as reported here where no audio output from the computer goes to the FXIII. I've tried the core audio trick but that didn't solve it for me either.

Will keep watching this thread to see if anyone has any answers.

Edit: Just tried a series of steps that seemed to work
1) In OSX, switch to another audio interface like macbook pro speakers
2) turn off Axe FX III
3) In your terminal, execute "sudo killall coreaudiod"
4) Turn on Axe FX III
5) Once fully booted (this is key), then select Axe FX III

The nuance here is that if you don't first select another interface (like built in speakers) before turning off the AXE and killing core audio, OSX will select the Axe FXIII automatically before the AXE has fully booted and I think that might be where the problem lies.

Thanks!
 

GlennO

Fractal Fanatic
I have been fighting this off and on for a while. Here are the problem and the symptoms (and potential workaround)...

I'm trying to follow the details...is the following correct?

You're using an aggregate device for your default audio output, but one of the devices of the aggregate (the axe fx) is not available because it is powered off. The problem occurs when you then turn on that missing device of the aggregate.

If so, the first troubleshooting question I would ask is: what if you only use the aggregate device that includes the AxeFX when the AxeFX is on? In other words, don't use that aggregate device when the AxeFX is off.
 
Last edited:

HeyimJoe

New Member
Hi all,

Brand new Fractal Audio customer here and had my FX III delivered on friday. I'm also experiencing the same issue as reported here where no audio output from the computer goes to the FXIII. I've tried the core audio trick but that didn't solve it for me either.

Will keep watching this thread to see if anyone has any answers.

Edit: Just tried a series of steps that seemed to work
1) In OSX, switch to another audio interface like macbook pro speakers
2) turn off Axe FX III
3) In your terminal, execute "sudo killall coreaudiod"
4) Turn on Axe FX III
5) Once fully booted (this is key), then select Axe FX III

The nuance here is that if you don't first select another interface (like built in speakers) before turning off the AXE and killing core audio, OSX will select the Axe FXIII automatically before the AXE has fully booted and I think that might be where the problem lies.

Thanks!
Was really hoping this was going to work. You go to system preferences>sound under input device select something other than axe fx then turn off axe fx. Open terminal type in the code. Then once axe fx is fully booted up. Select it under system preferences sound? Just making sure I didn’t make an error in the steps listed. Has this been a one and done permanent fix for you?
 
Was really hoping this was going to work. You go to system preferences>sound under input device select something other than axe fx then turn off axe fx. Open terminal type in the code. Then once axe fx is fully booted up. Select it under system preferences sound? Just making sure I didn’t make an error in the steps listed. Has this been a one and done permanent fix for you?

That's right. I've actually found I don't even need to run the terminal command (MacOS 10.15.3). Turn off AXE, under pref > sound, select internal macbook speakers, boot up Axe (wait until you see the preset screen), then re-select Axe FX in the sound output.
 

HeyimJoe

New Member
That's right. I've actually found I don't even need to run the terminal command (MacOS 10.15.3). Turn off AXE, under pref > sound, select internal macbook speakers, boot up Axe (wait until you see the preset screen), then re-select Axe FX in the sound output.
Has this permanently resolved the issue. Or do you have to do this everytime you wanna use the axe fx?
 
Has this permanently resolved the issue. Or do you have to do this everytime you wanna use the axe fx?
It only happens occasionally but I take my laptop to work and have the audio set to a different output there so when I come home and turn on the AXE on, I always just wait to select it as an output until its booted. I'll try to pay more attention this weekend the specific times that I have to use this work around.
 

grape

Experienced
I'll see what I can do to get the right person at Apple to look into this.

Guess what? It worked when I updated to 12.07 under OSX 10.15.4. I updated several AxeFXs and didn’t have to reboot! Are you aware of any changes that were made? I assume it was due to the 10.15.4 update...
 

grape

Experienced
Spoke too soon... last two beta installs (restart of an axefx in general) cause core audio issues with the following behavior until the Mac is restarted:

On restart of an axefx, the issue when it says “flash” or shortly after.

Mac is able to play audio out (from Music app) to a thunderbolt 3 interface and all of the AxeFXs other than the one that was restarted.

Daws are not able to play through Any aggregate device that includes the Axefx that was restarted. They are able to play through the other devices individually and any aggregate that doesn’t include the restarted device.

Pulling the usb cable and reinserting on the axefx that was restarted and currently running fixes the issue.

The usb unplug and plug didn’t work for me previously but it’s faster to pull the hub that they are connected to instead of restarting the computer. Still would be nice to figure fix what’s happening when the AxeFX starts up.
 

Loyarn

New Member
=
Understood just trying to eliminate possibilities...
I have the same problem on my win10 system. Until I saw what you said, I can finally make it sound again when the computer and fx3 are turned off at different times! Although I still don't know how to avoid this happening. . .
 
Top Bottom