• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Axe-Fx III Firmware Version 3.00

lqdsnddist

Axe-Master
I don't know if it was exclusively FW3.0, or maybe earlier and I just haven't tried it in a while, but must say the phaser block is sounding pretty exceptional right now. Can really get those over the top, hollow/resonant, 10 stage style phasing tones, ala the Phase 100, Boss PH-2, Maestro etc. now, that were always a little elusive before. Felt like I'd max out all the values and still not quite get there, but now its sounding great.

Like everyone else, I've spent a few hours doing swells with the new reverbs too lol
 

1poorplayer

Forum Addict
Loving these new reverbs! For modern praise and worship, they are perfect (we love our verbs, ha).

Here is a quick video I put together showing all 5 of the new verb types. The playing starts about 01:28 into the video

I had to hear this twice. Nice. I haven’t touched the verbs yet. I’ve been too caught up , playing my own presets since the update.
....off to the studio.
 

jakbur

Veteran
Possible bug 3.00
Front panel Nav controls not working on graphic EQ since update(stuck on last freq adjusted). Working for other parameters.
Anyone confirm?
 
Last edited:

jrogg75

New here
Possible bug 3.00
Front panel Nav controls not working on graphic EQ since update(stuck on last freq adjusted). Working for other parameters.
Anyone confirm?

Same.... I can navigate to other frequencies.... but the highlighted blue marker doesn’t follow along.... so you are blindly tabbing across frequencies until you begin to adjust the value knob.... at which point you can now see which ones you are on.

I reverted to 2.05 and reloaded 3.0 just to see if it corrected.... but it doesn’t.
 

Rekster

Inspired
I have to admit I got lost in playing swells tonight as well... :p

I've only had the Axe FX III for a month now and one of the first things I was missing was the cloud reverbs like on my Strymon BigSky. Then this surprise... it's like Christmas all over again.

I'm completely blown away by this product and it's continuous updates and improvements. There's been at least 3 updates alone since I started using it, including this major update. Cliff Chase and his team are absolutely amazing. (And the user community is top notch as well) Very few companies give so much and continue to give for a product they sell. The Axe FX III is inspiring me beyond belief to experiment, and more importantly - write music. Keep up the good work, I wish you continued success.
 
Top Bottom