• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Axe-Fx II and Linux (again)

krash73

Inspired
Volt are you still around? Can you help a Linux Mint dummy install the drivers? Every time I run the sh I get stuck at the user agreement. with no options.
 

volt

Inspired
Hi krash73,

thanks for using the script.

I don't have experience with Linux Mint specifically but ran the script successfully under Ubuntu which Mint is based on. I would expect the script to work with Mint, too. Let me see how far you got:

After starting the script from a terminal you should see
Code:
Install Fractal Audio Systems USB Bootloader
and then
Code:
Press any key to proceed with the Fractal Audio Systems Axe-Fx Software License Agreement. After reading it [COLOR=#ff0000]press [q][/COLOR].
So at first you need to press some key to see the license agreement. I assume you did that and got stuck when the license text is already been displayed. To proceed you have to type q. Did you do that, too?

Pressing q should quit displaying the license text and lead to

Code:
Press [y] to accept the Fractal Audio Systems Axe-Fx Software License Agreement or any other key to cancel.

P.S. Don't forget to run the script as super user.
 

krash73

Inspired
Got it working. I had to put it all on my destop in a folder and cd to desktop, the sudo to folder sh. Thanks, Volt
 

charndt

New here
Edit: Got it to work by cd'ing to the script directory, then running it from there using

Code:
sudo ./axefx2setup.sh
___

Hey Volt,

Another Linux Mint (17.2 Cinnamon 64 bit) newbie trying to get this to work. The first time I started the script from the terminal as a super user (sudo /path/to/axefx2setup.sh as you suggested), I got

Code:
Install Fractal Audio Systems USB Bootloader

Press any key to proceed with the Fractal Audio Systems Axe-Fx Software License Agreement. After reading it press [q].
I pressed a key, then this came up (note that this all comes up at once, with no chance for me to press [y]):

Code:
License: No such file or directory
cat: License: No such file or directory


Press [y] to accept the Fractal Audio Systems Axe-Fx Software License Agreement or any other key to cancel.


Installation cancelled. Press any key...
Currently, every time I run the script, the first code box is the same, but the second is this:

Code:
License: No such file or directory
cat: License: No such file or directory


Press [y] to accept the Fractal Audio Systems Axe-Fx Software License Agreement or any other key to cancel.
I press [y], which gives this:

Code:
The bootloader firmware file axefx2load.hex has not been found.


Installation failed. Press any key...
The file axefx2load.hex is in the same directory as the script. Am I missing something obvious?

Immense thanks for getting this to work!
 
Last edited:

volt

Inspired
Hi charndt,

thanks for using the script. Glad you figured it out. :)

The script was written to be run from the location it was stored to. Therefore in the case you described, the current version misses the license text. If nothing gets in the way I will have a new version ready soon ;-) which should allow to be run from a different directory the script itself is stored and also via a link to the script. A missing license text file will still end the installation process though (by intent), because the hex file is authored by FAS.
 

volt

Inspired
A new version of my script is available here: axefx.fr

The package containing the script is called "Axe-Fx_II_USB_Driver_Setup_Linux_103.zip".

Now it is possible to run the script from any location (i.e. from outside of its own directory). So this issue charndt (and I think also krash73) had experienced should be eliminated. Running the script through a link placed anywhere is also supposed to work.

Uninstalling had been straightened (I hope): To uninstall simply run the same script with the option "-u" (without the quotes).


Many thanks to AlGrenadine who is so kind to host the file. :encouragement:
 

volt

Inspired
Version 1.04 of the script is ready. Again, many thanks to AlGrenadine for hosting the package file in his AxeFX Archive where you can download from.

The script now checks if it is executed with root permissions and aborts where necessary. It also checks the Linux kernel version to be sufficient for the USB audio interface of the Axe-Fx II and offers a little information what functionality will (probably) be achieved in case an older kernel has been found. Furthermore, after there have been some revisions of the script now, I decided to add a command line option ("-v") to query the version of the script.
 

Awazah

New here
Going to add a note here: If you are having trouble getting axe-edit to connect to the axefx with wine -- make sure the wineprefix is configured for alsa before installation of axe-edit. I tried switching it from pulse to alsa after installation, and it just wouldn't bite -- set up a new wineprefix preconfigured, and everything worked beautifully.
 

PALYGAP

Veteran
I've just used axefx2setup.sh v1.04 on a Raspberry Pi 2 with Raspbian Wheezy (based on Debian). Works great.

The only things is that when I use lsusb I get :
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 1397:00bc BEHRINGER International GmbH BCF2000
Bus 001 Device 006: ID 2466:8003

last line is for the AXE-FX and there is no label.

But in my program ALSA list it properly as : AXE-FX II 24:0

amidi -l gives :

Dir Device Name
IO hw:1,0,0 BCF2000 MIDI 1
IO hw:2,0,0 AXE-FX II MIDI 1

Thanks a lot for the scipt volt
 

volt

Inspired
Thanks Palygap, glad to see the script is useful :)

For better identification of the Axe-Fx II by lsusb search for the file called usb.ids and just add the following lines:
Code:
2466  Fractal Audio Systems
    8003  Axe-Fx II
Important: The second line has to begin with a TAB. So if you copy and paste the code snippet replace the four blanks with a TAB.
 
Last edited:

PALYGAP

Veteran
I added the lines to /usr/share/misc/usb.ids and now lsusb says :

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 1397:00bc BEHRINGER International GmbH BCF2000
Bus 001 Device 006: ID 2466:8003 Fractal Audio Systems Axe-Fx II

I just had to put a TAB before "8003 Axe-Fx II" so that worked properly.

Thanks :)
 

volt

Inspired
Great!

Yes, the second line has to begin with a TAB. I guess that didn't translate well to the code snippet above which I copied and pasted. It seems the forum function to insert code unfortunately converts TABs to single blanks. I wasn't aware of that, so thanks for the hint.
 

reynolds087

New here
Hi, I'm trying to run the script to load the firmware and when I run it, it shows the license but it never prompts me to type "y" to accept. The only thing I can do is type "q" which terminates the process. Here is the message after I type "q"...

8. MISCELLANEOUS
The failure of either party to exercise in any respect any right provided for herein will not be deemed a waiver of any further rights hereunder. If any provision of this Agreement is found to be unenforceable or invalid, that provision will be limited or eliminated to the minimum extent necessary so that this Agreement will otherwise remain in full force and effect and enforceable. This Agreement will be governed by and construed in accordance with the laws of the state of New Hampshire without regard to the conflict of laws provisions thereof. Both parties agree that this Agreement is the complete and exclusive statement of the mutual understanding of the parties and supersedes and cancels all previous written and oral agreements, communications and other understandings relating to the subject matter of this Agreement, and that all modifications must be in a writing signed by both parties, except as otherwise provided herein. No agency, partnership, joint venture, or employment is created as a result of this Agreement and you do not have any authority of any kind to bind FAS in any respect whatsoever. In any action or proceeding to enforce rights under this Agreement, the prevailing party will be entitled to recover costs and attorneys' fees. All notices under this Agreement will be in writing and will be deemed to have been duly given when received, if personally delivered; when receipt is electronically confirmed, if transmitted by facsimile or e-mail; the day after it is sent, if sent for next day delivery by recognized overnight delivery service; and upon receipt, if sent by certified or registered mail, return receipt requested.-e

Press [y] to accept the Fractal Audio Systems Axe-Fx Software License Agreement or press any other key to cancel.
axefx2setup.sh: 37: read: Illegal option -n
-e

Installation cancelled. Press any key...
axefx2setup.sh: 37: read: Illegal option -n
~/AxeFXII$
 

volt

Inspired
PALYGAP is probably right. Make sure you are using bash and not sh. Have a look at this thread from post #12 on: http://forum.fractalaudio.com/threads/linux-support.108934/#post-1303724. Post #22 contains a short explanation what happens.

Also, what version of the script are you using? You get the info by running the script with the command line option -v. Latest version is 1.04. Previous versions needed to be executed from the location the script has been stored to.
 
Last edited:
Top Bottom