• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Bug? After converting an FM3 preset to the III, changing modifier assignment doesn't work correctly

luckymethod

Member
I have downloaded the great FM3 presets from Leon Todd (thank you) and loaded them on my Axe 3. All is well except most of those presets have a wah and it's mapped to Pedal 1 which I don't have. When I try to remap it to my external controller 1, nothing happens at first. Then I realized you first have to select "none" and then selecting external controller 1 works.

I have a video where I reproduce the issue:


Hope this helps.
 

iaresee

Moderator
Moderator
I tried this with an Axe-Fx III preset and can't reproduce the problem. I can change the modifier without passing through None and it works.

FM3 presets
I think this is the problem. The conversion process from an FM3 preset to an Axe-Fx III preset has some bad state in it that gets wiped when you set the controller source to None.

Link to the preset? I'll see what happens if I download and convert the exact same preset here.
 

iaresee

Moderator
Moderator
Yup. That's exactly what it is. When converting an FM3 preset to the III, you have to set the modifier source to NONE before you can assign it to anything else and have it work.

You can save the preset after you've got a modifier working, change away and then change back, and now you no longer have to move through the NONE setting to alter the modifier's source. I can go straight from External 1 to External 2 and it works as expected.

Nice catch!
 

iaresee

Moderator
Moderator
@Michael Pickens easy to replicate with the attached FM3 preset.

Load it into a III. The controller on the wah block is non-functional. Change it to anything other than NONE and it stays non-functional. Change it to NONE and then change it to something else and it'll begin to function.
 

Attachments

Top Bottom