• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

AES effect loop input/return level

sean.e

Inspired
I'm using AES for an effect loop using out 2 and in 2 (near the end of the grid after amp block and most effect blocks). When I bypass input 2, the level for the block drops by about 19dB. To level my presets (that use the AES loop) with factory presets (or any preset that does not use the AES loop), I have to either reduce AES output level on my external device, or reduce AES input level in AxeFxIII global i/o settings.

I've confirmed the external device is not causing a gain increase. The meters page for the preset shows the in 2 block input and output levels are the same when in 2 is active (and the external device is set for basic thru operation), but when in 2 block is disabled, the block output level is cut in half (tested with simple 4 block single row preset: in1 -> out2 -> in2 -> out1).

Is this expected behavior?
 

skategeezer

Inspired
I'm using AES for an effect loop using out 2 and in 2 (near the end of the grid after amp block and most effect blocks). When I bypass input 2, the level for the block drops by about 19dB. To level my presets (that use the AES loop) with factory presets (or any preset that does not use the AES loop), I have to either reduce AES output level on my external device, or reduce AES input level in AxeFxIII global i/o settings.
I've confirmed the external device is not causing a gain increase. The meters page for the preset shows the in 2 block input and output levels are the same when in 2 is active (and the external device is set for basic thru operation), but when in 2 block is disabled, the block output level is cut in half (tested with simple 4 block single row preset: in1 -> out2 -> in2 -> out1).

Is this expected behavior?
I guess I should ask what are you using as a external effects processor.
Also why not 1/4 in and outs?
 
Last edited:

is9582

Power User
Is there any reason you can’t use I/O3 instead of I/O2 for your loop? Just make sure to crank the front hardware knob for either I/O3 or I/O4 fully clockwise (wide open). Hope this might help.
Lee
 

sean.e

Inspired
AES is a digital format that has dedicated in/out sockets on the AxeFx. It doesn't work using analog 1/4" in/out. The front hardware output knobs do not affect the digital out levels by design. Using digital i/o prevents 4 audio conversions (digital to analog leaving AxeFx, analog to digital entering the H8000, digital to analog leaving the H8000, analog to digital returning to the AxeFx).
 

skategeezer

Inspired
AES is a digital format that has dedicated in/out sockets on the AxeFx. It doesn't work using analog 1/4" in/out. The front hardware output knobs do not affect the digital out levels by design. Using digital i/o prevents 4 audio conversions (digital to analog leaving AxeFx, analog to digital entering the H8000, digital to analog leaving the H8000, analog to digital returning to the AxeFx).
Got it using the H8000. Fancy. It does also have analog 1/4 in’s and out’s.
I would give that a go and see if the you can work around the leveling issue.
 

sean.e

Inspired
I've got a workaround -- reduce AES input level (as stated in the first post of the thread).

I'm wondering if that is normal behavior for digital return or if there is some other configuration setting that I need to change.
 
Last edited:

skategeezer

Inspired
I've got a workaround -- reduce AES input level.

I'm wondering if that is normal behavior for digital return or if there is some other configuration setting that I need to change.
Hmm that makes sense. Glad to hear you got it worked out.
 

is9582

Power User
Thanks for the details. I’m old school and haven’t ever dipped my toes into that realm. Best of luck with this.
 

Evohe

New Member
I have the same behavior with USB, the signal entering the grid from a digital source is increased by +18dB.

I attached a screenshot :
Synth block into Out 1, Synth level set to -12.0dB
On my DAW (Reaper) one track with Out1 Block as input, USB 7/8 as output, monitoring enabled, volume at 0.00dB
Out 2 show that the signal coming from USB is +18dB higher

Same result with Spdif using another audio interface, with Reaper and Cubase


I think it is the expected behavior because on an empty preset with only In 1 block directly connected to Out 1 block, if I record my guitar, the DI track (USB In 5/6) is 18Db lower as the "processed' coming from Out 1 block.
 

Attachments

  • 2021913-9540.png
    2021913-9540.png
    419.5 KB · Views: 5

sean.e

Inspired
That's pretty thorough, thanks.

I wonder if the difference in level is related to the handling of AxeFx internal headroom?
 

Bakerman

Axe-Master
It's due to Outputs 1 & 2 not being unity gain by design. Specifically Out 2 for initial loop scenario, but Out 1 affects the synth/DI test in post #9.

Reducing level at the Input 2 block is the easiest solution, unless you need less level sent into the external device for some reason. I think the exact value is -19.5 dB, even though this post is referring to the FM3: https://forum.fractalaudio.com/threads/out-2-low-volume.159030/post-1900129
 

sean.e

Inspired
For anyone following along, AES can't be selected for Out 3 or 4, so no unity gain loop via that route.

Reducing global AES input level by 18dB does the trick.

Alternatively, trying your suggestion, reducing Input 2 block output level by 9dB gives the same result -- not sure why the necessary reduction is halved... (the loop is not in a parallel path).
 
Top Bottom