• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

#%%^$£ USB

yek

Legend!
My Mac Mini M1 has USB-A and USB-C ports.

If I connect the FM3 or III to a USB-C port, the connection fails after the Mac has gone to sleep for a while. The editor disconnects and the ports just disappear in the editor (Settings > Preferences > Ports).

Tried and tested a lot of USB-C to USB-B cables. No difference.

I have to disconnect the cable and reconnect it, or power up the processor or computer to re-establish the connection.

First I thought that my monitor (also connected through USB-C) was the culprit, sucking up all the USB power. But no, the issue persisted after switching the monitor to HDMI.

I re-arranged the connections, switched the FM3 and III to USB-A, and everything now works as expected.

Sigh, USB …
 
Last edited:

chris

Legend!
I use a powered USB-A hub that connects via USB-C and haven’t noticed this on the M1 mini. I’ll see if I can recreate.

So it’s USB-C ports that are the issue?
 

iaresee

Administrator
Moderator
I use this hub:

Amazon product
Have for three years -- works flawlessly. The key is it stays powered up even if my iMac goes to sleep. I hang three to four Fractal units off it, my Scarlet 18i20 interface, a handful of external drives and they all work flawlessly. If my iMac goes to sleep and everything is powered up, I come back and it wakes up and everything continues to work.
 

skategeezer

Inspired
My Mac Mini M1 has USB-A and USB-C ports.

If I connect the FM3 or III to a USB-C port, the connection fails after the Mac has gone to sleep for a while. The editor disconnects and the ports just disappear in the editor (Settings > Preferences > Ports).

Tried and tested a lot of USB cables. No difference.

I have to disconnect the cable and reconnect it, or power up the processor or computer to re-establish the connection.

First I thought that my monitor (also connected through USB-C) was the culprit, sucking up all the USB power. But no, the issue persisted after switching the monitor to HDMI.

I re-arranged the connections, switched the FM3 and III to USB-A, and everything works as expected.

Sigh, USB …
I use my M1 MBP live with a USB-C to USB-A adapter and I do not have this issue.
What MacOS version are you running? 11.5.2?
 

Blix

Inspired
I have the last Mini before M1, which has a bunch of C's and 2 A's, using an unpowered hub in one of the A's,the cable from the III goes there.
Works great with everything plugged into the hub, only my audio interface and flight yoke is connected with USB-C, no issues there. :p
 

skategeezer

Inspired
the adapter is key.
Sorry I intended to type cable actually a USB-C printer cable. This is the one I am using.

Cable Matters USB C Printer Cable (USB C to USB B Cable, USB-C to Printer Cable) in Black 6.6 Feet​


Also what version of Mac OS are you updated to?
 

randyman

Experienced
But isn’t that the same as just disabling Sleep mode …?

Yes, but you can do it easily, quickly, and with a high degree of specificity directly from the menu bar … and you don’t need to remember to go back and turn sleep mode back on.
 
  • Like
Reactions: yek

skategeezer

Inspired
But isn’t that the same as just disabling Sleep mode …?
This was a very common bug that Apple fixed in a update. I had this issue with external display now coming back on after sleep as well.
I am on 11.5.2 and I do not have this issue.
Suggest you update to 11.5.2 the latest build and it should resolve your issue.
 

Greg Ferguson

Fractal Fanatic
Yes, but you can do it easily, quickly, and with a high degree of specificity directly from the menu bar … and you don’t need to remember to go back and turn sleep mode back on.
I just set the app up. It looks useful, if for no other reason than it can keep the screen from sleeping while I have one of the editors open.
 
Top Bottom