• We would like to remind our members that this is a privately owned, run and supported forum. You are here at the invitation and discretion of the owners. As such, rules and standards of conduct will be applied that help keep this forum functioning as the owners desire. These include, but are not limited to, removing content and even access to the forum.

    Please give yourself a refresher on the forum rules you agreed to follow when you signed up.

Fractal Audio Systems Forum

P
PaulC
Thanks for the info. I sent an email directly to Tom and haven't heard back yet. I will wait a bit and if no response then I will follow your lead. It seems either they are over burdened by returns based on a poorly designed product or they just don't have a way to manage the returns they get. 6 months is a long time...

Thanks again for the help
P
PaulC
Hi, did you ever get your control module back? I have not heard from Atomic for at least a month now and got no response from Tom King. I put a message on their Facebook page and I don't think it is active. I see messages on there from people thinking they have gone out of business?
Which forum did you post to?
R
Ripley
Hi Paul, I posted on the Atomic amps Forum. Tom King has replied to my emails twice since my last post. once in reply to a mail asking when they were going to post it (as they still hadn't after more than a week, and a second time when the tracking number they sent me was still showing that the USPS had still not received the package.
R
Ripley
It took 9 days for Atomic to actually post the CLR module after raising the shipping label. I have just checked again on the USPS tracking site with the tracking number they sent me, it has arrived at Heathrow London today and is saying 'in transit to final destination' so hopefuly should get it in the next day or two.
Top Bottom